Unable to perform Search Query


(Ayoola Ayooluwa) #1

I encountered this error in my search field: I would appreciate if i can get it fixed asap… Thanks


(Jan Doberstein) #2

did you check if your elasticsearch server is reachable?


(Ayoola Ayooluwa) #3

It should…what’s the path to check that so i would confirm.


(Jochen) #4

You can find the relevant file locations in the documentation at http://docs.graylog.org/en/2.3/pages/configuration/file_location.html

Make sure to check the logs of Graylog and Elasticsearch.


(Ayoola Ayooluwa) #5

Screenshot of graylog server.logs

Screenshot: elasticsearch/graylog.log

I will appreciate if u can look through and point out the errors i made. Thanks


(Jochen) #6

Graylog is unable to access the configured Elasticsearch node.

Are Graylog and Elasticsearch running on the same machine?
What’s the output of the following command if you execute it on the machine running Graylog?

curl -i 'http://127.0.0.1:9200/?pretty'

BTW, copying the text of the log files into your posts instead of uploading a screenshot would vastly improve the usability.


(Ayoola Ayooluwa) #7

Yes, they are running on the same machine.

And i got this error when i ran that command:

curl: (7) Failed connect to 127.0.0.1:9200; Connection refused


(Jochen) #8

You should probably start Elasticsearch.


(Ayoola Ayooluwa) #9

Thanks all. i have fixed it.


(system) #10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.