Unable to install Sidecar 1.3.0 on Windows 10/11

1. Describe your incident:
Installing the 1.3.0 version cannot continue, when installing on top of an older version this happens:

and then it waits there forever.

and when installing with no previous versions installed this happens:

2. Describe your environment:

  • OS Information:
    Windows 10 21H2 (19044.1288) / 11 22H2 (22621.819)
  • Package Version:
    Versions 1.2.0 and 1.3.0-beta.1 installs normally, only 1.3.0 has the problem, both x64 and x32 releases.
  • Service logs, configurations, and environment variables:
    Nothing unusual, very basic configurations.

3. What steps have you already taken to try and solve the problem?
I tried to delete older versions, then tried x64 and x32 releases of 1.3.0, after that tried installing on top of older versions (installing with and without administrator privileges)

4. How can the community help?
Since I tried on 2 different machines, I suspect the problem is not on my end, anyone else having this issue?


Copy the old Graylog-Sidecar configuration file then before installing newer version of Graylog-Sidecar & ensure there is nothing left behind from the older version (i.e., services, folders, etc…).

Looking at the output shown above did you configure the Sidecar configuration file?

C:\\Program Files\\Graylog\\sidecar\\sidecar.yml on Windows.

Next screenshot, Unable to open file error. Did you check permission on that file?

By chance did you install the service?

"C:\Program Files\graylog\sidecar\graylog-sidecar.exe" -service install
"C:\Program Files\graylog\sidecar\graylog-sidecar.exe" -service start

I have previously installed the service this way of course, uninstalling Sidecar 1.2.0 seems to also uninstall the service automatically, which is good.

The folder does not exist after uninstalling 1.2.0, but I also tried installing 1.3.0 after having first installed 1.2.0 and the folder permissions are ok, I own the folder and its files (as an administrator) and I’m running 1.3.0 installer as an administrator as well.

Screenshot from 2022-12-13 09-07-49

I am going to try installing on a fresh Windows install, but even if that works, I must figure out how to install 1.3.0 on my production machines.

I have just tried installing 1.3.0 on a fresh Windows 10 22H2 and I had the same results as before, I’m convinced now that the installer has some problems. Where can I report the issue?

Hello @Alper
Yes you can here is the link.

I have seen issue with beat log shipper on Win 11 but I have a few Windows server 2019 without issues.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.