Unable to Install Graylog

(Jseiser) #1

This is my first time using ansible. Im trying to configure graylog with an AWS Elasticsearch node.

Here is my playbook.


The result is that graylog doesnt come up.

TASK [Graylog2.graylog-ansible-role : Wait for Graylog server to startup] *******************************************************************************
fatal: [ec2_justin_graylog_dev]: FAILED! => {"changed": false, "elapsed": 300, "failed": true, "msg": "Timeout when waiting for"}
	to retry, use: --limit @/home/ubuntu/deployments/graylog.retry

PLAY RECAP **********************************************************************************************************************************************
ec2_justin_graylog_dev     : ok=28   changed=2    unreachable=0    failed=1   

Looking at the logs, I think its indicating an issue with mongodb.


Any help would be great.

(Jochen) #2

Correct, MongoDB doesn’t seem to run.

Have you been reading the documentation for the Graylog Ansible role?

Also take a look at these related issues:

(Jseiser) #3

I have been reading them, thats how I got the variables etc to be in the playbook.

I believe this should be what I need to get mongodb installed.

graylog_install_mongodb: True

If you are implying im missing something obvious, awesome, can you help me know what that is?


(Jochen) #4

What was the full output when you ran the playbook?

(Jseiser) #5

Full output.


(Jseiser) #6

I modified the playbook from

graylog_install_mongodb:       False


graylog_install_mongodb:       True

and I actually see things mongodb related, but it fails to start, and the log file is empty.

(Jochen) #7

Care to share some details?

(Jseiser) #8

OK, got it sorted out.

I had to install the mongodb repo from galaxy, then enable install mongodb in the playbook. I killed the instance I was working with and brought up a new one and that one installed without issue. So I think I attempted so many things I ruined the first instance.

(system) closed #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.