Unable to connect to Active Directory

Description of your problem

When trying to connect Graylog to Active Directory, user connection always fails. I’ve tried different users with the same result.
Server connection is succesful: https://i.imgur.com/g79qSQA.png
User connection fails: https://i.imgur.com/nrdbGZP.png

Description of steps you’ve taken to attempt to solve the issue

Tried to login with different users without success. Tried pointing to another DC.

Environmental information

Operating system information

(Debian 11.0.12 on Linux 5.10.0-8-amd64)

Package versions

Graylog 4.1.6+8a875ab
Mongod v4.2.16
Elasticsearch 7.10.2

Full error:

There was an error fetching a resource: Bad Request. Additional information: Cannot construct instance of org.graylog.security.authservice.backend.ADAuthServiceBackendConfig$Builder, problem: Missing required properties: userSearchBase at [Source: (org.glassfish.jersey.message.internal.ReaderInterceptorExecutor$UnCloseableInputStream); line: 1, column: 507] (through reference chain: org.graylog.security.authservice.test.AutoValue_AuthServiceBackendTestRequest$Builder[“backend_configuration”]->org.graylog.security.authservice.$AutoValue_AuthServiceBackendDTO$Builder[“config”])

Self explanatory, IMHO. There is a problem with ‘Search Base DN’ parameters in ‘User Synchronization’ section

1 Like

Hello ,
Quick question.

Did you 100% make sure that user you want to authenticate, is member of Organization unit (OU)?
If not, you want to find users in another OU.

1 Like

I thought “User Authentication” was the next step and that I had to validate both Server Connection and User Login at the first screen…

Once I realized my mistake everything was smooth and integration with AD works as expected now.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.