Unable to change default index used by 'All messages' stream


(Jo ) #1

Continuing the discussion from Unable to change default index in Graylog2:

Is there a way to get around this?I’m using Graylog 2.3.0


(Sachin) #2

You can change the name of the default index in the server.conf file.
elasticsearch_index_prefix = graylog


(Jo ) #3

Changing the server.conf file doesn’t work


(Sachin) #4

That you need to do when you install Graylog and before starting it for the first time.


(Jo ) #5

I’ve tried that. Even deleted the the index and restarted - no changes. Read somewhere on the documentation that these settings were moved to the database so I changed from the web interface which alters the number of shards but not the index name.


(Jan Doberstein) #6

@Bumble0b33

check the version you use and the documentation

http://docs.graylog.org/en/2.3/pages/configuration/server.conf.html#elasticsearch

In addition we have identified a bug in the GUI that will be fixed in 2.4

https://github.com/Graylog2/graylog2-server/issues/4376


(Jo ) #7

Thanks @jan - I solved it by updating the entry directly in the database


(Jan Doberstein) #8

you could have used the API which is working. It is only the GUI that is broken.


(system) #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.