Troubleshooting alert test, unsuccessful


#1

Hello, I’m in the same situation than this coleague: Could not send test alert notification

Jochen said “Check the logs of your Graylog node for details about the error.”, I read the following page in order to find the log files: http://docs.graylog.org/en/2.4/pages/configuration/file_location.html#default-file-location

I don’t have this directory at all: /var/log/graylog-server/

In running the virtual appliance, version 2.4.6-1.

Please help!
Thanks so much.
Charly.


(Tess) #2

Well, I don’t know where the logs are on that virtual appliance, but you could always sudo find / -name "server.log"

Also, perform basic troubleshooting on the network connection you’re trying to make.

  • Can the VM resolve the hostname for the mail host?
  • Can you ping it?
  • Can you connect to the port indicated using netcat?
  • Can you use another application to send mail through that host+port?

#3

Ok, I’ll do that find, but I’ve that in different version, also the log file changes its name, not only its path.

I’m simply trying to send a test mail with a Gmail account, so I’m trying to reach smtp.gmail.com. From Ubuntu’s console, ping responds just fine, pinging the hostname resolves to its IP address. I didn’t check those 2 last bullets, but I’m not blocking anything going out through my firewall.
Thanks!


(Tess) #4

That’s an interesting point… Does GMail still allow you to send emails simply with username and password? Or does it require application-specific passwords for all setups? In my case I had to create a seperate password for my desktop mail app.


(Jan Doberstein) #5

The defaults for the virtual appliance are just a little down the same page: http://docs.graylog.org/en/2.4/pages/configuration/file_location.html#omnibus-package

To give the mail settings in the appliance please check this command section: http://docs.graylog.org/en/2.4/pages/configuration/graylog_ctl.html#configuration-commands


(system) closed #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.