Troubles while generating reports

Dear Graylog Community,

Since I reinstalled a fresh new Graylog server in latest version, I have this issue while generating reports :

{"type":"ApiError","message":"invalid cookie domain\n  (Session info: headless chrome=96.0.4664.110)\nBuild info: version: '4.1.2', revision: '9a5a329c5a'\nSystem info: host: 'hostname', ip: '', 'Linux', os.arch: 'amd64', os.version: '5.10.0-18-amd64', java.version: '17.0.4'\nDriver info:\nCommand: [138b28b2db062b79d978d63eccac78d6, addCookie {cookie=authentication=**********; path=/;secure;}]\nCapabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 96.0.4664.110, chrome: {chromedriverVersion: 96.0.4664.110 (d5ef0e8214bc..., userDataDir: /var/lib/graylog-server/rep...}, goog:chromeOptions: {debuggerAddress: localhost:32921}, javascriptEnabled: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: LINUX, platformName: LINUX, proxy: Proxy(), se:cdp: ws://localhost:32921/devtoo..., se:cdpVersion: 96.0.4664.110, setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify, webauthn:extension:credBlob: true, webauthn:extension:largeBlob: true, webauthn:virtualAuthenticators: true}\nSession ID: 138b28b2db062b79d978d63eccac78d6\nBuild info: version: '4.1.2', revision: '9a5a329c5a'\nSystem info: host: 'hostname', ip: '', 'Linux', os.arch: 'amd64', os.version: '5.10.0-18-amd64', java.version: '17.0.4'\nDriver info: driver.version: unknown"}

My configuration : Graylog 4.3.8+8c4705e on Debian 11, with free enterprise license (2G/day).

Has anyone already faced this issue ?

Many thanks in advance for your answers,


There was a post not to long ago about this here. The person never came back to say it was resolved but it may help put you on the path to resolving it…

If you do, post and mark the solution for future searchers! :smiley:

1 Like

That was me. I didn’t get back before the post was closed. I can confirm that @patrickmann’s solution worked. Here is the link: Reports: "ApiError" "invalid cookie domain/n" - #5 by patrickmann

It was indeed the config option for self-signed TLS certificates option that fixed my problem.


I marked it as the solution over there - thanks for chiming in!! :smiley:

1 Like

Hi @tmacgbay @cttjern,

Thank you very much for your fast answers.

I added the “report_accept_insecure_certs = True” line in my server.conf and now it works flawlessly !

That’s great !

Have a nice day :smiley:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.