Error while generating reports

Hi dear Graylog Community members,

I tred unsuccessfully to generate reports following this tutorial : Setup - Reporting (

Each time, I have the following error that appears in my browser :

{“type”:“ChromedriverError”,“message”:“Error occurred during startup of chromedriver.\nStartup Logs: ChromeDriver was started successfully.\n\nRoot Cause: Could not start a new session. Response code 500. Message: unknown error: Chrome failed to start: crashed.\n (unknown error: DevToolsActivePort file doesn’t exist)\n (The process started from chrome location /usr/share/graylog-server/bin/headless_shell_amd64 is no longer running, so ChromeDriver is assuming that Chrome has crashed.)\nBuild info: version: ‘4.1.2’, revision: ‘9a5a329c5a’\nSystem info: host: ‘[hostname]’, ip: ‘’, ‘Linux’, os.arch: ‘amd64’, os.version: ‘[os version]’, java.version: ‘11.0.15’\nDriver info:\nCommand: [null, newSession {capabilities=[Capabilities {browserName: chrome, goog:chromeOptions: {args: [–headless, --disable-gpu, --disable-extensions, --disable-notifications, --disable-plugins-discovery, --disable-sync, --disable-translate, --disable-background-networ…, --disable-default-apps, --no-experiments, --no-first-run, --log-level=3, --enable-logging=stderr, --user-data-dir=/var/lib/gr…], binary: /usr/share/graylog-server/b…, extensions: }}], desiredCapabilities=Capabilities {browserName: chrome, goog:chromeOptions: {args: [–headless, --disable-gpu, --disable-extensions, --disable-notifications, --disable-plugins-discovery, --disable-sync, --disable-translate, --disable-background-networ…, --disable-default-apps, --no-experiments, --no-first-run, --log-level=3, --enable-logging=stderr, --user-data-dir=/var/lib/gr…], binary: /usr/share/graylog-server/b…, extensions: }}}]”}

I found several topics about the report generation problems, but I did not found anything regarding this error.

My configuration : Debian 10, Graylog 4.3.2, small business licence.

Many thanks in advance for your help.

Are you using the browser on the Linux machine? It may be an older version of Chrome and not compatible with what you are doing

Well, it’s a server so I don’t have any GUI… The Chrome software was not in the list of required packages in the documents I followed while installing, so I don’t really understand why it needs Chrome to generate reports


You may want to look here for more information on Reports.
and I quote:

You can create a report on the “Operations/Reports” page in the web interface.”

Any browser will do. Firefox works pretty good, Chrome can have issues from time to time.

You can use another device that does have a browser to connect to Graylog Web UI. if your using Localhost , or you may need to rethink you network configuration to something like a static IP address or FQDN in Graylog configuration file.

Hi @gsmith,

Thanks for the link. I’ve already followed that tutorial, but it does not work for me. I can access the menu, configure the reports and send them by email. Everytime, it fails, because of a serverside chrome dependancy (first logs I posted on this topic).

That’s what I don’t understand, why is this thing crashing ? For browsing the web, I’m using Edge (chromium) or Firefox, and in every case I get the same error while attempting to generate a report from the web ui.

So I think it’s not related to a web browser issue or something like this. :grimacing:

This line in the log files is clearly pointing on a Graylog Server component, but I did not install chrome manually on this server so far. :thinking: If someone could help me to undestand what all of this means, I would be very grateful.

What I was implying here is that on the server I can’t use a web browser using any ui but I can of course run firefox in command line. I can access it via another IP address than it’s localhost :wink:

Hi @gsmith and @tmacgbay,

After reading several topics, I finally solved my issue thanks to this one (outdated, but it worked for me). For some reason, things are not always as easy as they seems.

  • I added some packages to my installation :
    chromium, libx11-6, libx11-data, libx11-dev

  • And the following line at the end of the server.conf file :
    report_disable_sandbox = true

After restarting the graylog server, this part works flawlessly.

Hoping that this post will help other people, thanks for your help ! :smiley: :+1:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.