Report Generation Error

I’m trying to generate a report using the Enterprise 3.0 feature set. I get the following error from the UI (IPs removed):

{"type":"ApiError","message":"Timed out waiting for driver server to start.\nBuild info: version: 'unknown', revision: 'unknown', time: 'unknown'\nSystem info: host: '<HOST HERE REMOVED>', ip: '<IP HERE REMOVED>', 'Linux', os.arch: 'amd64', os.version: '3.10.0-957.5.1.el7.x86_64', java.version: '1.8.0_191'\nDriver info: driver.version: unknown"}

I see the following error message in /var/log/graylog/server.log:

2019-02-15T11:50:12.632Z ERROR [OsProcess] org.apache.commons.exec.ExecuteException: Process exited with an error: 127 (Exit value: 127)

2019-02-15T11:50:12.745Z ERROR [AnyExceptionClassMapper] Unhandled exception in REST resource

org.openqa.selenium.WebDriverException: Timed out waiting for driver server to start.

Build info: version: 'unknown', revision: 'unknown', time: 'unknown'

System info: host: '<HOST REMOVED>', ip: '<IP REMOVED>', 'Linux', os.arch: 'amd64', os.version: '3.10.0-957.5.1.el7.x86_64', java.version: '1.8.0_191'

Driver info: driver.version: unknown

at org.openqa.selenium.remote.service.DriverService.waitUntilAvailable( ~[?:?]

at org.openqa.selenium.remote.service.DriverService.start( ~[?:?]

at ~[?:?]

at ~[?:?]

at ~[?:?]

at ~[?:?]

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_191]

at sun.reflect.NativeMethodAccessorImpl.invoke( ~[?:1.8.0_191]

at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:1.8.0_191]

at java.lang.reflect.Method.invoke( ~[?:1.8.0_191]

at org.glassfish.jersey.server.model.internal.ResourceMethodInvocationHandlerFactory$1.invoke( ~[graylog.jar:?]

at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher$ ~[graylog.jar:?]

at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.invoke( ~[graylog.jar:?]

at org.glassfish.jersey.server.model.internal.JavaResourceMethodDispatcherProvider$ResponseOutInvoker.doDispatch( ~[graylog.jar:?]

at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.dispatch( ~[graylog.jar:?]

at org.glassfish.jersey.server.model.ResourceMethodInvoker.invoke( ~[graylog.jar:?]

at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply( ~[graylog.jar:?]

at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply( ~[graylog.jar:?]

at org.glassfish.jersey.server.ServerRuntime$ [graylog.jar:?]

at org.glassfish.jersey.internal.Errors$ [graylog.jar:?]

at org.glassfish.jersey.internal.Errors$ [graylog.jar:?]

at org.glassfish.jersey.internal.Errors.process( [graylog.jar:?]

at org.glassfish.jersey.internal.Errors.process( [graylog.jar:?]

at org.glassfish.jersey.internal.Errors.process( [graylog.jar:?]

at org.glassfish.jersey.process.internal.RequestScope.runInScope( [graylog.jar:?]

at org.glassfish.jersey.server.ServerRuntime.process( [graylog.jar:?]

at org.glassfish.jersey.server.ApplicationHandler.handle( [graylog.jar:?]

at org.glassfish.jersey.grizzly2.httpserver.GrizzlyHttpContainer.service( [graylog.jar:?]

at org.glassfish.grizzly.http.server.HttpHandler$ [graylog.jar:?]

at com.codahale.metrics.InstrumentedExecutorService$ [graylog.jar:?]

at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:1.8.0_191]

at java.util.concurrent.ThreadPoolExecutor$ [?:1.8.0_191]

at [?:1.8.0_191]

Caused by:$TimeoutException: Timed out waiting for [http://localhost:9515/status] to be available after 20000 ms

at ~[?:?]

at org.openqa.selenium.remote.service.DriverService.waitUntilAvailable( ~[?:?]

... 32 more

Caused by: java.util.concurrent.TimeoutException

at java.util.concurrent.FutureTask.get( ~[?:1.8.0_191]

at ~[graylog.jar:?]

at ~[?:?]

at org.openqa.selenium.remote.service.DriverService.waitUntilAvailable( ~[?:?]

... 32 more

Note: If I monitor the system for port 9515 – I never see a listener brought up for the report generator.

Please use proper formatting - without that your posting is nearly impossible. So quick, edit your posting and surround the log message with ``` like described in the FAQ:

That makes it more likely that someone can help you.

Formatting has been added per your request.

How did you install Graylog and the enterprise plugins?

I used the RPM distribution method of installation. I followed the CentOS installation instructions.

Hi Dustin,

Could you please verify that the folder indicated in the bin_dir option of your Graylog configuration file has the following binary files?


Also make sure that those binaries have the right permissions (and owner) so that the user executing Graylog server can also execute them.

Hope that helps.

The local graylog server is running under the ‘graylog’ user. The permissions show read and execute for all users:

     4 -rwxr-xr-x. 1 root root       798 Feb 11 13:57 graylog-server
111944 -rwxr-xr-x. 1 root root 114627328 Feb 11 13:58 headless_shell
     4 -rwxr-xr-x. 1 root root       132 Feb 11 13:58
  8368 -rwxr-xr-x. 1 root root   8565408 Feb 11 13:58 chromedriver

The directory is accessible for the graylog user account as well. Any other ideas?

Is that the bin_dir directory set in your Graylog server configuration file?

Also, could you try executing both the headless_shell and chromedriver binaries on a normal shell and share the output with us?

Sure thing – here you go:

./chromedriver: error while loading shared libraries: cannot open shared object file: No such file or directory
[danders@ip-172-32-10-253 bin]$ ./headless_shell 
[0215/] locale_file_path.empty() for locale 
[0215/] No usable sandbox! Update your kernel or see for more information on developing with the SUID sandbox. If you want to live dangerously and need an immediate workaround, you can try using --no-sandbox.
#0 0x000003efdfdf <unknown>
#1 0x000003e81a50 <unknown>
#2 0x00000515db40 <unknown>
#3 0x000003e34103 <unknown>
#4 0x0000051644b8 <unknown>
#5 0x000003e2d3a1 <unknown>
#6 0x000003f20ee8 <unknown>
#7 0x000003f20f75 <unknown>
#8 0x000003e6aa72 <unknown>
#9 0x7f0896c8b3d5 __libc_start_main
#10 0x00000259202a _start

Received signal 6
#0 0x000003efdfdf <unknown>
#1 0x000003efdb51 <unknown>
#2 0x7f089832f5d0 <unknown>
#3 0x7f0896c9f207 __GI_raise
#4 0x7f0896ca08f8 __GI_abort
#5 0x000003efc985 <unknown>
#6 0x000003e81ec2 <unknown>
#7 0x00000515db40 <unknown>
#8 0x000003e34103 <unknown>
#9 0x0000051644b8 <unknown>
#10 0x000003e2d3a1 <unknown>
#11 0x000003f20ee8 <unknown>
#12 0x000003f20f75 <unknown>
#13 0x000003e6aa72 <unknown>
#14 0x7f0896c8b3d5 __libc_start_main
#15 0x00000259202a _start
  r8: 00007f08989537c0  r9: 0000000000000002 r10: 0000000000000008 r11: 0000000000000206
 r12: 00007ffd7925d638 r13: 0000000000000161 r14: 00007ffd7925d640 r15: 00007ffd7925d648
  di: 0000000000001611  si: 0000000000001611  bp: 00007ffd7925cc90  bx: 00007ffd7925ccf0
  dx: 0000000000000006  ax: 0000000000000000  cx: ffffffffffffffff  sp: 00007ffd7925cb58
  ip: 00007f0896c9f207 efl: 0000000000000206 cgf: 0000000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.

I installed libX11 (yum install libX11) which resolved the chromedriver execution issue. However, here is the new error message I receive when trying to invoke a report from the UI:

{"type":"ApiError","message":"unknown error: Chrome failed to start: exited abnormally\n  (unknown error: DevToolsActivePort file doesn't exist)\n  (The process started from chrome location /usr/share/graylog-server/bin/headless_shell is no longer running, so ChromeDriver is assuming that Chrome has crashed.)\n  (Driver info: chromedriver=72.0.3583.1 (9ae827a6f6bbc9186d4e79681de885ce77d5bfe9),platform=Linux 3.10.0-957.5.1.el7.x86_64 x86_64) (WARNING: The server did not provide any stacktrace information)\nCommand duration or timeout: 67 milliseconds\nBuild info: version: 'unknown', revision: 'unknown', time: 'unknown'\nSystem info: host: '<HOST>', ip: '<IP>', 'Linux', os.arch: 'amd64', os.version: '3.10.0-957.5.1.el7.x86_64', java.version: '1.8.0_191'\nDriver info: driver.version: RemoteWebDriver"}

@unixfun looks like you are running a RedHat/CentOS system with a pretty old kernel. Either update to a 4.x kernel or disable reporting sandbox with: report_disable_sandbox = true
In the server configuration file.

Interesting note is that I used the default AWS 7.5 Centos Base image and it has a 3.x kernel. I upgraded the kernel to 4.2 and still received an error with headless_shell looking for I installed chromium-libs-71.0.3578.98 after running yum whatprovides '*/*' and restarted graylog. With the addition of this package, I was able to successfully create a report.

I suggest additional Linux requirements be added to the documentation for future users. Thanks for the help!

Cool that it is working now for you! We will add more details to the documentation soon. The error regarding libGLES could be ignored, since in headless_mode no graphic acceleration is needed anyways.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.