Traffic load balance

Before you post: Your responses to these questions will help the community help you. Please complete this template if you’re asking a support question.
Don’t forget to select tags to help index your topic!

1. Describe your incident:
I have three nodes, but all the traffic goes to the master node. How can I load balance the traffic to these three nodes? If haproxy is used, how to configure it.

2. Describe your environment:

  • OS Information:
    centos 8
    graylog 4.2.2

  • Package Version:

  • Service logs, configurations, and environment variables:
    Is it okay to follow this configuration?

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]


Looks like your other two node are not processing any messages “0”.
Not sure what you have done or how you configured your cluster, so its hard to identify where the issue is.
What documentation did you use to create this cluster?
Perhaps some more information would help, if your unsure please look here for a better understanding.

frontend graylog_http
bind *:80
option forwardfor
http-request add-header X-Forwarded-Host %[req.hdr(host)]
http-request add-header X-Forwarded-Server %[req.hdr(host)]
http-request add-header X-Forwarded-Port %[dst_port]
acl is_graylog hdr_dom(host) -i -m str
use_backend graylog

backend graylog
description The Graylog Web backend.
balance roundrobin
option httpchk HEAD /api/system/lbstatus
http-request set-header X-Graylog-Server-URL
server graylog1 maxconn 20 check
server graylog2 maxconn 20 check
server graylog3 maxconn 20 check


Not sure what configuration that is for, so I assume it elasticsearch. If that correct I see why your having problems, I’m also referring to package install. If this is Docker I’m not going to be much help.

I installed it with yum. There are currently 3 nodes. I want to use a haproxy to load balance the traffic. How to configure it? Now the traffic goes to the master node. The other two nodes are in restricted state, which leads to a backlog of messages on the master node.

You may need to read this documentation, It will explain how to set that up for you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.