TLS Configuration Graylog v3

Hi everyone,

First of all I would like to say that I am new and French, so sorry if I dont answer to the rules of the forum or if my english is bad.

So I start working on Graylog for 2 weeks now. I just try to put HTTPS / TLS for my server and you know what ? It works. But there is something I want to know. I followed the v3 official documentation and a video for the v2.4 Graylog. At the beginning of this video, we modify a file : /etc/sysconfig/graylog-server

In this file he add this :

At the end of the TLS configuration he use and I use a command that I guess there is a link between the line above. The command is : keytool -importcert -keystore /path/to/cacerts.jks -storepass changeit -alias graylog-self-signed -file cert.pem

I found for the second time the password “changeit” I only use the last command above but I dont put the first line I said. I tried to change the password when I used keytool command but it return me this : Keystore was tampered with, or password was incorrect

So I tried to add the line in /etc/sysconfig/graylog-server and change the password and next use again the keytool command but its still the same problem. To sum up my TLS works but I want to change this password but I dont know how or where I need to change it.

Someone have a idea for the v3 version ?

Thanks for help and sorry for my english

Change the password like this it’s not something I got in mind ! Thanks for your help

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.