Syslog Inputs are missing from fresh installations


(Ameen Ali) #1

Hi.

I just finished RPM installation and noticed that Syslog inputs are completely missing from the platform, and as they are not available for installation separately, no syslog messages can be received.

Expected Behavior
To have Syslog UDP / TCP inputs available in inputs list.

Current Behavior
Only inputs available are Beats, 3 AWS Inputs (Flow, Logs, and CloudTrail, and 2 CEF Inputs (AMQP & Kafka)

Possible Solution
Manual import of Syslog inputs?

Steps to Reproduce (for bugs)
Regular Centos 7 64bit installation via RPM. SELinux/FW aren’t the issue.

Context
I noticed that after the installation, rsyslog daemon wasn’t running, and no config was applied to it. I enabled the listeners for TCP/UDP and manually started it, then restarted Graylog without luck.

Your Environment
Centos 7 64bit installation via RPM

Graylog Version: graylog-server-2.4.3-1.noarch
Elasticsearch Version: elasticsearch-5.6.8-1.noarch
MongoDB Version: mongodb-org-3.6.3-1.el7.x86_64
Operating System: CentOS Linux release 7.4.1708 (Core)
Browser version: Chrome 65


Missing Syslog as an input type
Syslog inputs missing from new installation
(Jochen) #2

Have you tried purging the cache of your web browser?

What’s the output of the following command? Please adapt the URL to the Graylog REST API accordingly.

# curl -H 'Accept: application/json' 'http://graylog.example.com/api/system/inputs/types?pretty=true'

Please post the complete logs of your Graylog node:
:arrow_right: http://docs.graylog.org/en/2.4/pages/configuration/file_location.html


(Ameen Ali) #3

You’re pretty much right. Using curl revealed that inputs are present, it was a browser issue.

Thanks.


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.