Some users get "Server Currently Unavailable" No Error


#1

Sometimes I get the following errors, along with other staff. Usually waiting fixes the issue and it may not affect all users at once. (Currently I can login but another staff member is getting this error). This usually clears itself up after a little while.

Looking through the Graylog logs I am not seeing any type of errors, no am I in ES logs.

pasted[1506955747]

Can someone point me to the right direction?


(Jan Doberstein) #2

hej @HanSolo71

it looks like your Graylog is under load and can’t handle the ingest, processing and showing the web interface at once.

look at the resources that are used.

regards
jan


#3

Current load via HTOP. It looks like I am using a tiny bit of paging memory. I have added more RAM to the ES process (While staying under 32GB) but never messed with the memory allocation for other processes.


(Jochen) #4

You could try increasing the number of threads for the Graylog REST API:


#5

@jochen

I increased it from 16 to 64 and have rebooted my system.

I am able to login, but my user who was having issues is still getting the same error.

I also increased my web_thread_pool_size from 16 to 32 with no change.


#6

@jochen and @jan

Could this be related to the following security errors I see when i login? It appears that something on the webpage is connecting with the self-signed graylog cert and I bet that is causing issues in browsers.

EDIT: I verified this was the issue. Had the user browse to https://10.0.1.245:9000/api/ and accept the cert and then login worked.

What have I misconfigured to cause this to happen?


(Jochen) #7

You’re using a self-signed certificate for the Graylog REST API.

Users will always have to accept these manually or better load your custom CA into their certificate stores.


#8

Got it, I can push those out since the Rest API must use a self signed cert so you can get the IP address in it.


(system) #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.