Set graylog server DNS


#1

I am using a Graylog 2.2.2 virtual appliance. How can I permanently set the DNS server? I can set it in resolv.conf temporarily, which gets reset, but can’t figure out the proper way to set it permanently. Thank you.


#2

Bump, I could really use some help with this if anyone can assist. Thank you.


(theresa) #3

Hi,

why would the DNS server get reset when they’re configured in the resolv.conf?
Is this file managed by a configuration management tool that constantly overwrites it?
I don’t think you can set this in the graylog config, however what you can do is install a dnsresolver plugin to resolve the IP addresses.

I hope that’s what you meant/intended to do.

cheers,
theresa


(Jan Doberstein) #4

The Appliance is only build as a showcase - if you run Graylog in production you should think about building your own and be able to customize the system.


(theresa) #5

Sorry to hijack this thread. But since I’m running the virtual appliance locally (as a test-environment). Is it possible to setup a TLS connection there as well?
in the graylog.conf I can only see the rest_tls_ settings but not the web_tls settings.
Would I need to add those myself or is this configured somewhere else? I can’t seem to find it how to configure it through graylog-ctl either.

best regards,
theresa


(Jan Doberstein) #6

Hej @micsnare

please do not hijack …

but you like to read the graylog-ctl documentation and options page.