Rest api via browser with nginx subdirectory

Hello,

Have seen several post on this…none of much help to me :disappointed:

I am testing 3.2.1 but waiting on some bug fix :smile:

I’ve always had an issue with accessing the rest api via the browser. Currently when click on API browser button for X node i have to manually change my browser URL to the valid URL but the web frontend is unusable. Nor is the Clustor Global API browser usable.

How my node API looks like (after i manually change my URL):

I dont quite understand why my browser looks like that. Using Google chrome.

How my Global API browser looks like and behaves (unusable) (still using google chrome):

my http_* settings in server.conf are all default. Commented out. Honestly always was confused by them.

My nginx config is exactly as documented here but with subdirectory.

Like I mentioned there has been much talk about this but never really some “official” way to make it work.

Is this still something that can be achieved? Perhaps with some nginx.conf settings or adjusting the http_* settings in server.conf?

Any input is much appreciated!

Thanks,
Dave

Something i forgot to test. without using subdirectory

Results:

Node API Browser:

  • still need to adjust URL manually
  • still no change. Looks the same. Blank screen with only username/password fields showing (see previous post)

Global Cluster API browser:

  • no need to adjust URL, no changes there
  • the Show/Hide buttons work fine (i can see GET POST etc) and get results back :+1:

So as it has to do with graylog running in a subdirectory

Hope this is helpful

Thanks!

I reported that streams problem with subpaths on 3.2.1 a few days ago. Today I found out about the api-browser today and found the same problem. Neither the node-specific api-browser nor the global one work for me behind nginx with a subpath.

However, at the office we have nginx in front of graylog without a subpath and I am not able to view the global cluster api-browser in that environment.

Perhaps this was a regression from 3.1 since it works for you.