Cluster Global API Browser and API Browser seems not right

I got ngnix configured for reverse proxy.

It is okay to access

But i am seeing following url
API Browser of node is

Cluster Global API Browser is

Is there anything wrong?

for api, i could curl successfully.

however the node REST API is showing

the API Browser is the Graylog server http_publish_uri what is the endpoint for each Graylog node and that is unique per Node. In a multi Cluster environment that URI is used to communicate in the cluster between each graylog node. This way you can connect to each nodes individual api browser

The Global API Browser is taking the http_external_uri as source - That is the point where your browser is able to reach Graylog (cluster) and what will connect to the API Browser - not one specific.

As this is a new feature the documentation is not (yet) reflecting that.

Thanks Jan.
I have only one node running on the host and I have the following configs in server.conf.

http_bind_address =
#http_publish_uri =
http_external_uri =

Is there anything I could do to have the correct url for API Browser and Global API Browser?


he @blam

you can always type in the URL yourself - regarding the button I guess you hit a bug with the global api browser.

would you please open a bug report over at Github?

Do you mind sharing your NGINX config?

That would allow us to check in detail.

    listen 80;
    include common.conf;

    location /graylog/
	include common_location.conf;
        proxy_set_header    X-Graylog-Server-URL http://$server_name/graylog/;
        rewrite             ^/graylog/(.*)$  /$1  break; 

    location /
	return 404;


add_header X-Frame-Options              SAMEORIGIN;
add_header X-Content-Type-Options       nosniff;
add_header X-XSS-Protection             "1; mode=block";


proxy_set_header    X-Real-IP           $remote_addr;
proxy_set_header    X-Forwarded-For     $proxy_add_x_forwarded_for;
proxy_set_header    X-Forwarded-Proto   $scheme;
proxy_set_header    Host                $host;
proxy_set_header    X-Forwarded-Host    $host;
proxy_set_header    X-Forwarded-Server  $host;
proxy_set_header    X-Forwarded-Port    $server_port;

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.