Responds by IP, not by DNS name

I run graylog in my home network. I have a couple of bind servers running as well, and I have a DNS entry for graylog, along with everything else. I nuked my graylog server and built a new one from the ground up, including a new Ubuntu Server 2010 instance.

When I configure it this way:

http_bind_address =

I can get to the graylog login page by IP address, but when I use graylog.home.lan:9000 I get this message:

We are experiencing problems connecting to the Graylog server running on http://graylog.home.lan:9000/api/ .

When I configure this:

http_bind_address = graylog.home.lan:9000

I get the opposite. Login page works at the URL, but the IP gives me this:

We are experiencing problems connecting to the Graylog server running on .

Is there something I have configured wrong somewhere? Running Graylog v4.0.5+d95b909, latest ElasticSearch 7.11, etc.

Good morning, I believe you are describing the expected and default behaviour.

If the bind address is an IP, then that’s how you access it. If the bind address is a FQDN, that’s how you access it.

I think if you want/need both to work you put a proxy out front.

Thank you, Zach.

Kinda strange default behavior if you ask me. LOL. I mean, why would you code for that? There’s probably a good reason that I am missing. Oh well. Thanks for your help!

Graylog is great at gathering and searching logs. But there are other side things that you either need to be an expert to accomplish or another product. Like the web interface. It seems to be a feature not a bug. You do get flexibility and options, but some times I wish the solution was a bit more “on rails”.

That being said, most of my issues would be solved with paying for it and support :slight_smile:

@WriteyPete see 4.0 upgrade - Browser access failure with DNS name but IP works - #4 by aaronsachs. You’re probably missing http_enable_cors = true. Also, I’d quite strongly suggest redeploying Elasticsearch as 7.10 and pinning the version. 7.11 is not supported and we don’t have an ETA as to if/when it will be.

1 Like

@aaronsachs I saw you say this on another post that 7.11 is NOT supported

Just specifies 7.x I would expect 7.11 to fall under 7.x Perhaps that can be updated to the versions that are supported?

Thank you, Zach.

Actually, 7.11 is a typo. My bad. It is actually running 7.10.X. So close, and yet so far… oh well.

http_enable_cors = true fixed the problem.

Thanks everyone!

Provide clarification about ES 7.10 v 7.11 in `Operating System Packages` page · Issue #1118 · Graylog2/documentation · GitHub submitted to add clarity about which packages are supported.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.