Remove count() from graphics

Hello.

I have plenty of histogrammes showing the necessary field values in dashboards. Everything was fine until upgrading to the 3 version.

Now in each graphic I have annoying ‘count()’ and if it’s removed, there’s no values at all!

Is there a way to get rid of it, but save the values themselves? Like it was earlier.

Thanks.

1 Like

Did you upgrade to Graylog 3.2?

Yes, I’m on 3.2.2 now.

Granted, for a single value histogram titled “Message Count” the y-axis is somewhat self explanitory. For me the source of irritation were the paranthese. You can change the texts of the legends in the edit window by clicking on the text (not the x) of a ‘metric’ that you have added to your chart.

Maybe, with a another legend text, these graphs will look acceptable to you?

This is the new design of the search.
And the History shows the count of the messages.

You can rename it., and save design. After you can use a browser bookmark, and it will open you favorite style.
kép

Thanks guys, but, you see, actually I’d like to remove that metrics completely. Why? Because I don’t need it in graphics. For example, 111

in that graphic I have two fields that I want to trace (the blue and orange ones). And everything would be OK, if not the count(), which just takes extra space (the green one). Even if I were to rename it, the bar would remain, right?

That’s why I want to remove it.

I see, I misunderstood you. In the edit window upper row next to the ‘columns’ is a small wrench. Click on that, disable “Roll up” and then this total count disappears.

By the way, we spent some considerable amount of time trying to figure that one out as well. It is somewhat unintuitiv.

2 Likes

Wow! Many thanks to you, kind man! :slight_smile: It’s precisely what I wanted!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.