Question: Is there way to disable the system-checking http requests on Graylog UI?


(Jay Won) #1

Hi all,

I just noticed that Graylog UI constantly makes http requests to the Graylog servers.

It keeps calling below APIs at about 10s interval.

  • /api/cluster/metrics/multiple
  • /api/system/cluster/nodes
  • /api/system/notifications

So I looked around the options of Graylog, but I couldn’t find out related options to disable them.

Those APIs are thought to be about system-checking like input throughput, notification and etc. But I want to disable them or adjust the interval, cause I think that it does not need to be constantly checked at about 10s interval. It is kind of distracting, too.

Is there any way to disable them?

Thanks for your support,


(Jochen) #2

No, these requests cannot be disabled.
https://github.com/Graylog2/graylog2-server/issues/3985


(Jay Won) #3

Hey @jochen, thanks for your reply and spending time.

I just read the github issue you have linked, but I couldn’t find out “why”. Could you tell me why you guys block them from being disabed? I’m just curious.


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.