Problems genarating report PDF


I’m have graylog installed with the docker-compose method (image: graylog/graylog:3.0, just rebuild so i have the latest version Graylog 3.0.2+1686930). Enterprise plugin version 3.0.2 is installed from tarball (binaries in /usr/share/graylog/bin and the .jar file in /usr/share/graylog/plugin)

graylog_1 | 2019-07-19 13:23:19,804 INFO : org.graylog2.bootstrap.CmdLineTool - Loaded plugin: Graylog Enterprise 3.0.2 [org.graylog.plugins.enterprise.EnterprisePlugin]

Trying to download a report PDF fails with error:

{"type":"ApiError","message":"unknown error: Chrome failed to start: exited abnormally\n (unknown error: DevToolsActivePort file doesn't exist)\n (The process started from chrome location /usr/share/graylog/bin/headless_shell is no longer running, so ChromeDriver is assuming that Chrome has crashed.)\n (Driver info: chromedriver=72.0.3583.1 (9ae827a6f6bbc9186d4e79681de885ce77d5bfe9),platform=Linux 4.15.0-54-generic x86_64) (WARNING: The server did not provide any stacktrace information)\nCommand duration or timeout: 81 milliseconds\nBuild info: version: 'unknown', revision: 'unknown', time: 'unknown'\nSystem info: host: '41b3e3cc353d', ip: '', 'Linux', os.arch: 'amd64', os.version: '4.15.0-54-generic', java.version: '1.8.0_212'\nDriver info: driver.version: RemoteWebDriver"}

as per suggestion on another post i tried running the headless-shell directly in the container

graylog@76c66dab06ed:~/bin$ ./headless_shell

[0719/] locale_file_path.empty() for locale

[0719/] No usable sandbox! Update your kernel or see for more information on developing with the SUID sandbox. If you want to live dangerously and need an immediate workaround, you can try using --no-sandbox.

running it with the --no-sanbox doesn’t help much

graylog@76c66dab06ed:~/bin$ ./headless_shell --no-sandbox

[0719/] locale_file_path.empty() for locale

[0719/] locale_file_path.empty() for locale
Fontconfig warning: "/etc/fonts/fonts.conf", line 100: unknown element "blank"

[0719/] Lost UI shared context.

[0719/] locale_file_path.empty() for locale

[0719/] Failed to load GLES library: /usr/share/graylog/bin/swiftshader/ cannot open shared object file: No such file or directory

[0719/] Exiting GPU process due to errors during initialization

Disabling the sanbox from graylog.conf and restart didn’t help either

report_disable_sandbox = true

When I try to download a report PDF i get gateway timeout from the nginx proxy, and no errors in the graylog logs

graylog_1        | 2019-07-19 13:37:49,463 INFO : - Starting report render engine: http://localhost:9515

graylog_1        | 2019-07-19 13:37:50,093 INFO : org.openqa.selenium.remote.ProtocolHandshake - Detected dialect: OSS

But as the ./headless_shell --no-sandbox didn’t work directly from the container either I didn’t really expect this to work either.

Is there an option to disable the GPU acceleration for the report generation? Or am I missing something else?


it looks like the fontconfig is not installed on your System:

The GPU error can be ignored.


Actually fontconfig is installed

root@501ac1539a9b:/usr/share/graylog# apt-get install fontconfig
Reading package lists... Done
Building dependency tree
Reading state information... Done
fontconfig is already the newest version (2.11.0-6.7+b1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

the error is:

Fontconfig warning: "/etc/fonts/fonts.conf", line 100: unknown element "blank"

not sure about that.


This comment indicated that it would be an issue with the version of chromium, however not sure if this applies here or how I could fix it if it does.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.