Generate Report Error

In enterprise 3.0 version, when I attempt to generate/download a report I receive this error:
{“type”:“ApiError”,“message”:“The driver executable does not exist: /bin/”}

I checked and that file is present. ideas?

Yeah, can the user that runs Graylog access the file? :wink:

Have you tried from that user’s shell, or with sudo -u graylog head /bin/ The latter assumes that the user running Graylog is graylog.


Yes the user can access/open the file (graylog)

I think it might be a path issue so I am trying some things here:

plugin_dir = /usr/share/graylog-server/plugin

bin_dir = /usr/share/graylog-server/plugin/bin/

also tried

plugin_dir = /usr/share/graylog-server/plugin

bin_dir = /bin


plugin_dir = /usr/share/graylog-server/plugin

#bin_dir =

Oh joy, it’s one of those relative path things? Meh…

Now, I don’t have 3.0 installed, so I’m feeling around in the dark a bit… What is the actual location of that script on the file system?

  • how did you install Graylog?
  • how did you installed the Enterprise plugins?
    • if you used the .tgz option of the plugins, did you place the content of bin to the Graylog bin folder?

Another small hint, in case you forgot to do it: ensure you restart the Graylog server process after changing the configuration file.

1 Like

This is the location


Hello- I used the command: sudo apt-get install graylog-enterprise-plugins
Then restarted the server (it is a single node).
I guess my question now is do other users have this working proper on 3.0?

1 Like

Well this was simple- it was a path issue. thanks everyone

1 Like

You mean literally the ${PATH} variable for the user account running Graylog? :smiley:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.