Problem with Version 3 upgrade

#1

"Version 2x was running fine. Upgraded to Version 3 and tried my best to convert the server.conf file to the new http variables but with no success. Below is the configuration that worked in Version 2…
What is the proper Version 3 variables and syntax needed to replace the
my working Version 2 configuration? I have tried many configurations that I thought should work with no joy.

rest_listen_uri = https:///jsfitpgraylog01.services.fit.local/api/

jsfitpgraylog01.services.fit.local/api/

rest_transport_uri = https:///jsfitpgraylog01.services.fit.local/api/

rest_enable_tls = true

rest_tls_cert_file = /etc/graylog/server/cert/graylog-certificate.pem

rest_tls_key_file = /etc/graylog/server/cert/graylog-key.pem

web_enable = true

web_listen_uri = https:///jsfitpgraylog01.services.fit.local/

web_enable_tls = true

web_tls_cert_file = /etc/graylog/server/cert/graylog-certificate.pem

web_tls_key_file = /etc/graylog/server/cert/graylog-key.pem"

0 Likes

#2

look at:
http://docs.graylog.org/en/3.0/pages/upgrade/graylog-3.0.html

There is a table with all changed configs. I hope this helps you :slight_smile:

0 Likes

#3

thanks but I was working with that document to try an convert the variables.

Nothing I tried worked so I thought if someone saw my working config from version 2

they could provide the correct syntax for version 3. I’ve spent hours trying different

combinations of syntax with no luck.

0 Likes

#4

But I refuse to take your config and write it for the new version. This is the job you get paid for and, even more important, you should know your own configs…
Instead I will try to explain the table of the docs so you can figure out what you should do next. I don´t want to be mean or evil. The pure solution just won´t help you in the future :slight_smile:

You got the rest_listen_uri at first. This one does not exist anymore.
The new setting is “http_bind_address”. http_bind_address needs IP:Port of your Graylog-Server. So what you do next is to remove “rest_listen_uri” in your config and add the new setting “http_bind_address” with your IP and port.
Default is 127.0.0.1:9000.

Then you go on with the same on each of your settings. You will notice that there are a few removed settings with an identical new one. Good for you, because you will need the new one only once.

0 Likes

(Jan Doberstein) #5

so what did you tried to use? Please post your not working configuration and we can help with that.

0 Likes

#6

Using the Version 3 Configuration file I tried this and other variations such as the IP address and https instead of http, putting port 80 or 443 at the end.
https:///jsfitpgraylog01.services.fit.local (unable to connect)
https:///jsfitpgraylog01.services.fit.local:9000 (tries but times out)

http_bind_address = jsfitpgraylog01.services.fit.local
http_external_uri = http:///jsfitpgraylog01.services.fit.local/
http_enable_tls = true
http_tls_cert_file = /etc/graylog/server/cert/graylog-certificate.pem
http_tls_key_file = /etc/graylog/server/cert/graylog-key.pem

The log shows:
2019-04-01T09:45:05.270-05:00 INFO [JerseyService] Enabling CORS for HTTP endpoint
2019-04-01T09:45:23.547-05:00 INFO [NetworkListener] Started listener bound to [jsfitpgraylog01.services.fit.local:9000]
2019-04-01T09:45:23.548-05:00 INFO [HttpServer] [HttpServer] Started.
2019-04-01T09:45:23.548-05:00 INFO [JerseyService] Started REST API at <jsfitpgraylog01.services.fit.local:9000>
2019-04-01T09:45:23.548-05:00 INFO [ServiceManagerListener] Services are healthy
2019-04-01T09:45:23.549-05:00 INFO [ServerBootstrap] Services started, startup times in ms: {OutputSetupService [RUNNING]=6, BufferSynchronizerService [RUNNING]=15, KafkaJournal [RUNNING]=19, JournalReader [RUNNING]=25, EtagService [RUNNING]=46, StreamCacheService [RUNNING]=47, ConfigurationEtagService [RUNNING]=51, InputSetupService [RUNNING]=60, PeriodicalsService [RUNNING]=67, LookupTableService [RUNNING]=136, JerseyService [RUNNING]=18681}
2019-04-01T09:45:23.549-05:00 INFO [InputSetupService] Triggering launching persisted inputs, node transitioned from Uninitialized [LB:DEAD] to Running [LB:ALIVE]
2019-04-01T09:45:23.553-05:00 INFO [ServerBootstrap] Graylog server up and running.

0 Likes

(system) closed #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

0 Likes