PagerDuty timed out

Hi all,
I saw that in our actual used Graylog Version 4.0.8 that an integration / notification via PagerDuty is possible.
I just wanted to setup PagerDuty but always run in an time-out.
We of course have an routing key etc. and I guess the initial config on the Graylog gui is correct.
Does the PagerDuty needs an proxy configuration? We have an Proxy configured currently only on OS level, not in the Graylog server.conf.
When I try to add the Proxy in the Server.conf I have issues, because it looks like the configured non_proxy_hosts are not working for me. After Node restart, the node cannot contact Elasticsearch anymore.
Or is it something else? Is there some additional configuration neccesarry for PagerDuty notifications?

Thank you very much in advance
BR,
Steffen

Welcome, Steffen, to the community! We’re glad you;ve joined us.

We’ve moved your post to our Daily Challenges where you can expect to get more expert eyes reading, and perhaps responding to it.

Check out this information from GitHub and let us know if it’s helpful.

1 Like

Hi David,
thank you very much for your answer. As far as I understood the PagerDuty got fixed and is now using the standard Graylog Proxy settings which is really good.
Maybe I have an issue with the NoProxy configuration?

http_non_proxy_hosts = localhost,127.0.0.1,localaddress,*.mydomain.org,10.*.*.*,10.27.*.*

If I add the Proxy in my server.conf the Graylog node does not connect the elasticsearch anymore. My Elasticsearch Servers are configured with the IP 10.*

Is there any mistake? Do I need to add https_non_proxy_hosts as well?

Thank you!
Regards,
Steffen

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.