Limiting the Search-Result

I’m currently trying to limit the logs I receive when using the Graylog API. According to the Graylog API I can use the limit parameter to reduce the amount of logs I will receive. The problem I am having is, that I always receive more logs, then I have specified in the parameter. For example when I specified 10 logs as the limit, I instead received approximately 1000 logs.

How does the limit parameter actually work? Can I limit the amount of logs I receive when using the Graylog API to an exact amount (e.g. exactly 10 logs)?

API:

 /views/search/messages

Body:

{
    "limit": 10,
    "streams": [
        "000000000000000000000001"
    ],
    "timerange": {
        "type": "relative",
        "range": 172800
    },
    "query_string": { "type":"elasticsearch",  "query_string":"" }
}

Which graylog version do you use?

Same issue version 3.3.5

Specifying chunk_size helped to limit message count.

1 Like

I’m using the version 4.05 and specifying chunck_size also worked for me.

Thanks for the tip!