API response limit in json


(FelixFV) #1

Hi!
I have similar problem as in


But my version of graylog is newest stabile

I have 2 nodes with 2.4.3 version:
Node ID:
a79139b1-eb44-4fd4-b028-3bb2022fe4fa
Version:
2.4.3+2c41897, codename Wildwuchs
and
Node ID:
9d619de9-d9a1-40d5-a2f2-21d0866ebc19
Version:
2.4.3+2c41897, codename Wildwuchs

for resolve json limit I have upgrade graylog today.
But in json response i get:
message[‘total_results’] = 988 (as example)
and length of messages array = 150 (with any relative timerange)

What I can do with this?


(Jochen) #2

Please provide some details about what requests you’re sending to the Graylog REST API, the responses to these requests, and some details what you’re trying to achieve.


(FelixFV) #3

my python request is:
query = ‘streams:000000000000000000000001’
fields = ‘_id,dest_ip’
range = str(30)
url=‘http://10.124.128.12:9000/api/search/universal/relative?query=’+query+’&range=’+range+’&fields=’+fields+’&decorate=true

in my case I need some aggregation actions in script. An d it needs lot of message in response.

If it is not possible - I’ll try another way


(Jochen) #4

The default page size is 150 items. If you want more result items, you’ll have to set the limit query parameter accordingly or page through the result set (see offset query parameter).


(FelixFV) #5

I add &limit=some-int to my URL and it works
thanks @jochen!


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.