LDAP settings not shown on UI after restart

If garylog restarts or something happens restart graylog. the LDAP setting are shown on UI but they exist in mongo collection. Is there are workaround for this ?

@shivoham can you please share your Graylog, ES and MongoDB version? Have you restarted your Graylog server service or MongoDB service?

Hello, thank you for response. Graylog version is 3.3.8, Mongo is 3.6 and we use AWS managed elastic search 6.8 versions. We have graylog in a pipeline filebeat->kafka->graylog->Managed elastic search. Due to some reason if we had restart graylog due to indexes messed up or something. The LDAP settings are Missing (in my original message it should have been ‘not shown’) on UI but they exist on mongo collection. We have to redo the LDAP setting every time this happens. Yes, we did restart few times still the same.

did you have set your Graylog salt static or is that created each time new?

What you describe like you have multiple Graylog with a different salt or you change the salt on every login.

We have not set anything specific called graylog salt static, googled a bit could not find what it is. We deployed graylog with helm and yes we have two graylogs one prod and other for non-prod but under different namespaces of kubernetes.

I referenced to the Graylog password_secret

Its just LDAP settings are missing in UI. Able to login to graylog as Admin no problem with that. The setting are available on mongo collections. Yes we have same secret on all graylog pods.

he @shivoham

that sounds like a bug - but one I have never seen before. Do you have multiple MongoDB Servers in your environment?

Okay we almost fixed it. We are using secret manager so that the root password does not set everytime it restarts.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.