LDAP not working


(Ayoola Ayooluwa) #1

Hello team, i tried configuring Graylog LDAP but it isnt working just yet and i am running Graylog version 2.4. I did the connection test and it worked perfectly but when i tried testing with a user, it failed.

Below are the error messages:

Kindly advise on what am not doing right.

Thanks


(Jochen) #2

The credentials for accessing the LDAP server are incorrect.

Please refer to http://docs.graylog.org/en/2.4/pages/users_and_roles/external_auth.html#ldap-active-directory for details about using LDAP or Active Directory with Graylog.


(Ayoola Ayooluwa) #3

I have read the documentation over and over @jochen.

But it still isnt working. The documentation isn’t detailed for the “User Mapping” Section.

Thanks


(Jochen) #4

There’s an issue on GitHub describing a similar problem:


(Ayoola Ayooluwa) #5

Hi @jochen, is it a must i configure the “Group Mapping” part for it to work fine? because i can see on the page that the part is optional.

Thanks


(Jochen) #6

The LDAP group mapping should be optional.


(Ayoola Ayooluwa) #7

I have removed the LDAP group mapping configuration and have been troubleshooting since but it still hasnt worked…any path to check again @jochen??


(bubba198) #8

Did you configure the LDAP account to be used when binding to AD? The little red box is the domain name in its NetBIOS form (not an FQDN)

~B


(Ayoola Ayooluwa) #9

yes i did…i went ahead to test the Server connection and it worked fine.


(system) #10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.