LDAP doesn't map groups


I have success with LDAP credentials but it’s not listing for me the groups, even they appear for me in the connection test.

My settings:




1 Like

It sees the groups exist for a user but it probably isn’t able to actually find the groups if you try to do the LDAP group to Graylog group mapping - without knowing how your AD/LDAP is laid out (I mean, groups under ou=users seems a bit weird) I can’t really say much :smiley:

So is this about the Group Search Pattern Group?

My settings are like this…

For me is strange because if it finds the groups I dont know why it´s not listing them… It gets the correct group of all users I tried. So i dont think this is a problem in the tree.

What LDAP server are you using? AD or OpenLDAP or something similar?

I’m using AD as server.

1 Like

Any news?
Is there some pattern installation for that? Another filter I can use for searchs?

Hi Camilla,

It all depends on your AD layout. Did you try the same ldap search query through another ldap client to validate it? And by another ldapclient I mean something else than AD tools leveraged by Microsoft.
I configured such a setup with our AD and it works ok.

We use OpenLDAP ourselves so any advice I have relates to that, all I remember about AD is that it requires a different group search filter to get the proper membership, but for the life of me I can’t remember the details…

I thinks it´s exactly something like this, because I have the groups already showing for me, but in a search for LDAP Groups settings I can´t find it.

I tried to configure my AD informations in a AD software and i worked fine.
I think the problem is not the configuration of AD because I have the groups in the test login, my problem is when I open the LDAP Groups tab, so it doesnt show me the groups…

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.