Issue with Dashboard after upgrading from 3.1 to 3.2

Hello,

I am getting an error as below while opening the dashboard tab after upgrading from 3.1 to 3.2

Could not retrieve dashboards
Fetching dashboards failed with status: Error: cannot GET http://serverip:9000/api/views/dashboards?query=&page=1&per_page=10&sort=title&order=asc (500)

I also get this error while i try to edit a profile.

Previously certain dashboard were created and assigned to certain roles for non admin users

Currently using the API I have deleted all the dashboards and still I get the error

Graylog version : 3.2.1+dbaac33, codename Ethereal Elk
Upgraded from : 3.1.4+1149fe1, codename Quantum Dog
Elastic version : 6.8.3
OS : CentOS Linux release 7.7.1908 (Core)

Any guidance would be appreciated.
Thank you

In the log file I ran the below command

[root@graylogsrv graylog-server]# cat server.log | grep -i migration | grep -i error

I get only the below error

2020-02-10T15:26:07.152+03:00 ERROR [MigrationHelpers] Invalid role ‘Views Manager’, fixing it

he @vmlenny

did you see any information about migration in the first startup logfile of Graylog after the update?

did you restart Graylog after you have deleted the dashboards?

@jan thank for you response.

The same error is there on the user profile page and I am not able to edit any user
and the dashboard page get stuck in “Loading views…”
Tried creating a simple count dashboard it successfully saves but when i go back to the dashboard page it does not load

did you see any information about migration in the first startup logfile of Graylog after the update?
below is the log i can find
2020-02-10T09:48:29.491+03:00 INFO [Periodicals] Starting [org.graylog.plugins.pipelineprocessor.periodical.LegacyDefaultStreamMigration] periodical, running forever.
2020-02-10T09:48:29.566+03:00 INFO [LegacyDefaultStreamMigration] Legacy default stream has no connections, no migration needed.
2020-02-10T09:48:29.587+03:00 INFO [Periodicals] Starting [org.graylog2.periodical.IndexRangesMigrationPeriodical] periodical, running forever.
2020-02-10T09:48:29.669+03:00 INFO [PeriodicalsService] Not starting [org.graylog2.periodical.UserPermissionMigrationPeriodical] periodical. Not configured to run on this node.

did you restart Graylog after you have deleted the dashboards?
Yes the server was restarted after the dashboards were deleted

Thank you

sorry - i have no idea how to solve that situation.

maybe @konrad?

Hello @vmlenny,

when you get the error, can you please take a look into the web dev console (usually reachable with F12)

There should be a line which is containing sometimes additional messages (like stack traces) to the error.

I am pretty sure you did already but just in case, did you take a look in to the server.log right after you clicked on the dashboards overview page to see if a stack trace can be found there?

@jan thank you for the efforts

@konrad

The below is the error i get form the web dev console

There was an error fetching a resource: cannot GET http://serverip:9000/api/views/dashboards?query=&page=1&per_page=10&sort=title&order=asc (500). Additional information: IOException encountered while reading from a byte array input stream

Below is the extract from the server.log… any suggestion as what to look for would be appreciated

https://pastebin.com/raw/3PtfR6Jy

Hi @vmlenny,

it seems the migration did something wrong here. We migrated the dashboards to views. Views are now dashboards. We can go now different roads to a solution.

  1. If you do not care about your saved searches and dashboards you could delete all of your mongodb documents of views.
  2. If you want to keep them and are you do not have a problem in sharing them, you can export them and show them to me and we try to fix the problem.
  3. You can fix it by yourself by going though your mongodb views documents and searching for the interval. One interval has a unit set which is not in the right format:
where quantity is a positive number and unit [smhdwM]

- Konrad

1 Like

@konrad

You solution was spot on. I deleted the document from mongodb and it fixed the issue

Thanks alot for your support

1 Like

@vmlenny, did you by chance see what was the content of the interval? So I can tyr to ivestigate what went wrong?

Happy that we got it working for you!

- Konrad

@konrad

I am sorry did not look into the interval. I Just deleted the first dashboard and it worked.
I know i should have looked at it before deleting.

Thank you again

Lenny

I have the similar issue, trying to find “wrong” in interval… WHAT is the wrong? scaling : null ??
Lots of clicking…

Just installed robo 3T and not sure how to use this (SQL to mongo):

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.