I can't get any logs in Search screen graylog3.0

Hello, I try to get logs from fluentd to graylog3.0 use GELF.
How can I get logs?

I get graylog from graylog-3.0.0-12.ova.
I setup Graylog-input following guidline↓

I send test command

echo -n ‘{ “version”: “1.1”, “host”: “example.org”, “short_message”: “A short message”, “level”: 5, “_some_info”: “foo” }’ | fluent-cat graylog2.test

then Graylog-Inputs(, I get some data as below
Throughput / Metrics
1 minute average rate: 0 msg/s
Network IO: 0B 0B (total: 23.4KB 0B )
Empty messages discarded: 0

and Graylog-Stream[All messages] ( some data as below
All messages index set Default index set Default
Stream containing all messages
1 messages/second. The default stream contains all messages.

but Graylog-search( says Nothing found.

How can I get logs? Please help me.
I have graylog 2.4 and I also setup same way with fluentd, I can get logs in Graylog-search.

td-agent --version

td-agent 1.3.3

Thank you.

Sherlock, it is time to check the complete way - if you ingest a message via netcat to Graylog does that show up?

Yes, add one moving part and check again - if no investigate …

Should your message be in the future, all message stream will not show that - as it search from now backwards and not showing all messages you have ingested no matter what time … maybe you should check that.

Hello. thank you for your reply.

echo -n ‘{ “version”: “1.1”, “host”: “example.org”, “short_message”: “A short message”, “level”: 5, “_some_info”: “foo” }’ | nc -w9 -u 12202

Input and Stream get some data, but Search says Nothing found.

Stream[All messages] is system default stream. so I can’t change any settings about [All messages].

you can select a specifc timerange from one day in the past till 1 week in the future to check if your messages does not have the “current” timestamp.

thank you for your reply.

I use VirtualBox.
I retry to install graylog-3.0.0-12.ova, and soon send the command
echo -n ‘{ “version”: “1.1”, “host”: “example.org”, “short_message”: “A short message”, “level”: 5, “_some_info”: “foo” }’ | nc -w9 -u 12202

then I can get logs!

I set NAT network and host-only-adapter in VirtualBox, but it’s bad for get logs.
I set nothing in VirtualBox, then I can get logs.

I apologize for the trouble. I’m sorry and thank you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.