How set index.mapping.total_fields.limit on my graylog virtual appliance create from OVA?


(Alessio Dapelo) #1

How set index.mapping.total_fields.limit on my graylog virtual appliance create from OVA ?
I recive this error :slight_smile:

  • {“type”:“illegal_argument_exception”,“reason”:“Limit of total fields [1000] in index [graylog_6] has been exceeded”}
    i can’t find the file to change this limit on my graylog
    tnx in advance

(Jan Doberstein) #2

You need to use a custom elasticsearch mapping ( http://docs.graylog.org/en/2.4/pages/configuration/elasticsearch.html#custom-index-mappings ) that includes the setting for future indices:

"settings" : {
    "index.mapping.total_fields.limit": 2000
  },

For the current index you can set it online via curl

PUT graylog_6/_settings
{
  "index.mapping.total_fields.limit": 2000
}

Read about the reason this settings exists in the Github Issue/PR: https://github.com/elastic/elasticsearch/pull/17357


(system) #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.