Guide: how to replace the default background in graylog 3.1.x (Ubuntu 18.04 LTS)

Hello,
Since i am modifying a lot of .jar files on daily basis (due to the fact we deploy them with jboss application server but we don’t have the source) at my workplace i’ve decided to make a little experiment with the graylog installation.

I strongly advise to NOT do anything from the below if you’re not confident what are you doing exactly.

Here’s a few steps that if you follow up carefully you will succeed in changing the default background.
0. Stop the graylog-server service

  1. Most important step is to take a backup of graylog.jar (for debian ubuntu it’s located here : /usr/share/graylog-server
  2. Download graylog.jar via FTP/SFTP to your local computer
  3. Open graylog.jar with 7zip (this is very important to do , otherwise you can break the integrity of the jar file)
  4. While inside of graylog.jar locate any files that have extension .jpg (for my case it was the selected one)
  5. Drag\n\Drop them from the .jar to your local folder and check them until you see the default background
  6. Pick up your new background and rename it onto exactly the same name as it is in the graylog.jar
  7. Drag\n\Drop the desired background from your local folder to graylog.jar in 7zip
  8. Upload the graylog.jar back to the server
  9. Start the graylog-server service and wait for it to fully start
  10. Enjoy your new background
3 Likes

@zay7sev
Nice thanks, no problems.

It works, thank You!

  1. it would be the coolest feature in graylog if it’s supported by the creators…
  2. Thanks for the information

But some warning
The file is provided by the graylog-server package (centos), so an update won’t work or will overwrite the changes (if you installed from package) (based on the package’s settings)
There are feature requests (for the official way), give a +1.


2 Likes

Hi @zay7sev ,
I would like to replace the default background in graylog, I work with Graylog 2.5 (Os : centos7) , I have tried many times, I want to follow a clear method.

Thanks

Hi @Labidi,
Unfortunately i haven’t tested this on CentOS, and i never used graylog below 3.1.x but it should be the same.
Locate the graylog.jar and execute the same steps.
Anyway even if we have this workaround i highly recommend to wait until a official feature is available to be used.

1 Like

Thanks a lot for your reply @zay7sev

JFYI, it works on CentOS 7 with Graylog 3.1, files are in the same locations.

1 Like

@zay7sev
I delete the photo that is in the web interface \ asests in the file graylog.jar and I replace it with the new one with the same name ?? now I have the background of graylog is white

Yes :star_struck::star_struck::star_struck::star_struck: thanks a lot @zay7sev

No problem @Labidi .
For your previous text.
You actually don’t delete the one inside, you just replace it with the new one.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.