Graylog2 Configuration


#1

I installed Graylog2 on Debian 8.
I had this error message (/var/log/graylog-server/server.log):

Unable to call http://192.168.1.38:12900/system/metrics/multiple on node <99b726bc-adb6-4de6-bd01-3977c7a03411>
java.net.ConnectException: Failed to connect to /192.168.1.38:12900

My config (/etc/graylog/server/server.conf):

rest_listen_uri = http://127.0.0.1:12900/
rest_transport_uri = http://192.168.1.38:12900/
web_listen_uri = http://127.0.0.1:9000/

Configuration (/etc/nginx/sites-available/default):

server
{
  listen      80 default_server;
  listen      [::]:80 default_server ipv6only=on;
  server_name graylog.graylog;

  location /api/
    {
        proxy_set_header    Host $http_host;
        proxy_set_header    X-Forwarded-Host $host;
        proxy_set_header    X-Forwarded-Server $host;
        proxy_set_header    X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_pass          http://127.0.0.1:12900/;
    }
  location /
    {
        proxy_set_header    Host $http_host;
        proxy_set_header    X-Forwarded-Host $host;
        proxy_set_header    X-Forwarded-Server $host;
        proxy_set_header    X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header    X-Graylog-Server-URL http://192.168.1.38/api;
        proxy_pass          http://127.0.0.1:9000;
    }
}

(Jochen) #2

Is the IP address 192.168.1.38 set up and reachable on the system running Graylog?
If not, why did you choose this for rest_transport_uri?


#3

Yes, the IP address is reachable on the system running Graylog.


(Jochen) #4

In that case you might want to use the correct URI to the Graylog REST API in your rest_transport_uri setting.

Hint: it ends with /api/ according to your nginx configuration.