First instalation in


(Adam) #1

Hi,
I test install graylog on CentOS and I have error in log and I didn`t know what is wrong in my configuration:
WARN [ProxiedResource] Unable to call http://192.168.1.120:12900/api/system on java.net.SocketTimeoutException: timeout
Could they give me an example of a valid config? What correct rest_listen_uri and rest_transport_uri(rest_listen_uri = http://192.168.1.120:12900/api)?
I suspect that error is in this line but I give this from example documentation


(Jan Doberstein) #2

valid configurations can be found in the documentation and if you followed one of our installation guides you should have a valid, working configuration.


(Adam) #3

Simple write “all in documentation” but I find other user that have the same problem and not have answer. I read documentation and try meny posibles. I didn`t write this topic if I find in documentation or in internet answer.
I try find mistake in my test configuration.


(Jan Doberstein) #4

Adam, sorry that you have that hard time - but the not present information from your end tend to provoke such a generic answer.

The Installation will include a working configuration where Graylog will listen on localhost. The configuration itself include those two settings that are commented and just need to be changed to a non-localhost address or wildcard.

Without knowing your configuration or your setup nodody will be able to help you.


(Adam) #5

I see this in documentation and I try change to 0.0.0.0 and error is no disapear:
my config


(Jan Doberstein) #6

your provided error message

WARN [ProxiedResource] Unable to call http://192.168.1.120:12900/api/system on java.net.SocketTimeoutException: timeout

Can’t be produced from the System with the configuration you provided

rest_listen_uri = http://0.0.0.0:9000/api/
web_listen_uri = http://0.0.0.0:9000/

You must use something else or an outdated installation guide.

Our Step-by-Step Guide wasn’t followed

http://docs.graylog.org/en/2.4/pages/installation/os/centos.html


(system) #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.