Cannot access graylog by web


(hamed) #1

I am new to Graylog, I am installing graylog on centos and I couldn’t get graylog2 web interface even i tried different browser.please i need your help
i will add the configurtion


(hamed) #2

#GRAYLOG CONFIGURATIO

Default is UTC

root_timezone = UTC

When using Graylog Collectors, this URI will be used to receive heartbeat messages and must be accessible for all collectors.

rest_listen_uri = http://192.168.1.5:9000/api/

This must not contain a wildcard address (0.0.0.0).

#rest_transport_uri = http://192.168.1.5:12900

Comma separated list of trusted proxies that are allowed to set the client address with X-Forwarded-For

header. May be subnets, or hosts.

#trusted_proxies = 127.0.0.1/32, 0:0:0:0:0:0:0:1/128


(hamed) #3

Enable the embedded Graylog web interface.

Default: true

#web_enable = false

Web interface listen URI.

Configuring a path for the URI here effectively prefixes all URIs in the web interface. This is a replacement

for the application.context configuration parameter in pre-2.0 versions of the Graylog web interface.

web_listen_uri = http://192.168.1.5:9000/

(Approximate) maximum number of documents in an Elasticsearch index before a new index

is being created, also see no_retention and elasticsearch_max_number_of_indices.

Configure this if you used ‘rotation_strategy = count’ above.

ATTENTION: These settings have been moved to the database in 2.0. When you upgrade, make sure to set these

to your previous 1.x settings so they will be migrated to the database!

elasticsearch_max_docs_per_index = 20000000

How many Elasticsearch shards and replicas should be used per index? Note that this only applies to newly created indices.

elasticsearch_shards = 1
elasticsearch_replicas = 0

A comma-separated list of Elasticsearch nodes which Graylog is using to connect to the Elasticsearch cluster,

see https://www.elastic.co/guide/en/elasticsearch/reference/2.3/modules-discovery-zen.html for details.

Default: 127.0.0.1

elasticsearch_discovery_zen_ping_unicast_hosts = 127.0.0.1:9300


(hamed) #4

Use multiple Elasticsearch nodes as seed

#elasticsearch_discovery_zen_ping_unicast_hosts = 198.51.100.23:9300, 198.51.100.42:9300

we don’t need to run the embedded HTTP server here

elasticsearch_http_enabled = false

for special values here

#elasticsearch_network_host =192.168.1.5
#elasticsearch_network_bind_host =192.168.1.5
#elasticsearch_network_publish_host =

HTTP proxy for outgoing HTTP connections

#http_proxy_uri =

proxied_requests_thread_pool_size = 32
mongodb_useauth=false

[root@pdc-graylog-01 ~]# systemctl status firewalld
? firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:firewalld(1)


(hamed) #5

[root@pdc-graylog-01 ~]# sestatus
SELinux status: disabled

[root@pdc-graylog-01 ~]# java -version
openjdk version "1.8.0_161"
OpenJDK Runtime Environment (build 1.8.0_161-b14)
OpenJDK 64-Bit Server VM (build 25.161-b14, mixed mode)
[root@pdc-graylog-01 ~]#

[root@pdc-graylog-01 ~]# systemctl status elasticsearch.service
? elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
Active: active (running) since Thu 2018-02-22 10:06:43 +04; 14min ago
Docs: http://www.elastic.co
Process: 1086 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)
Main PID: 1100 (java)
CGroup: /system.slice/elasticsearch.service
±1100 /bin/java -Xms256m -Xmx1g -Djava.awt.headless=true -XX:+Use…

Feb 22 10:06:51 pdc-graylog-01 elasticsearch[1100]: [2018-02-22 10:06:51,213]…
Feb 22 10:06:51 pdc-graylog-01 elasticsearch[1100]: [2018-02-22 10:06:51,213]…
Feb 22 10:06:55 pdc-graylog-01 elasticsearch[1100]: [2018-02-22 10:06:55,623]…
Feb 22 10:06:55 pdc-graylog-01 elasticsearch[1100]: [2018-02-22 10:06:55,624]…
Feb 22 10:06:55 pdc-graylog-01 elasticsearch[1100]: [2018-02-22 10:06:55,857]…
Feb 22 10:06:55 pdc-graylog-01 elasticsearch[1100]: [2018-02-22 10:06:55,863]…
Feb 22 10:06:58 pdc-graylog-01 elasticsearch[1100]: [2018-02-22 10:06:58,905]…
Feb 22 10:06:58 pdc-graylog-01 elasticsearch[1100]: [2018-02-22 10:06:58,931]…
Feb 22 10:06:58 pdc-graylog-01 elasticsearch[1100]: [2018-02-22 10:06:58,931]…
Feb 22 10:06:58 pdc-graylog-01 elasticsearch[1100]: [2018-02-22 10:06:58,991]…
Hint: Some lines were ellipsized, use -l to show in full.
[root@pdc-graylog-01 ~]# systemctl status mongod.service
? mongod.service - SYSV: Mongo is a scalable, document-oriented database.
Loaded: loaded (/etc/rc.d/init.d/mongod; bad; vendor preset: disabled)
Active: active (running) since Thu 2018-02-22 10:06:46 +04; 14min ago
Docs: man:systemd-sysv-generator(8)
Process: 1087 ExecStart=/etc/rc.d/init.d/mongod start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/mongod.service
±1376 /usr/bin/mongod -f /etc/mongod.conf

Feb 22 10:06:43 pdc-graylog-01 systemd[1]: Starting SYSV: Mongo is a scalabl…
Feb 22 10:06:43 pdc-graylog-01 runuser[1148]: pam_unix(runuser:session): ses…)
Feb 22 10:06:46 pdc-graylog-01 runuser[1148]: pam_unix(runuser:session): ses…d
Feb 22 10:06:46 pdc-graylog-01 mongod[1087]: Starting mongod: [ OK ]
Feb 22 10:06:46 pdc-graylog-01 systemd[1]: Started SYSV: Mongo is a scalable…
Hint: Some lines were ellipsized, use -l to show in full.


(hamed) #6

[root@pdc-graylog-01 ~]# systemctl status graylog-server.service
? graylog-server.service - Graylog server
Loaded: loaded (/usr/lib/systemd/system/graylog-server.service; enabled; vendor preset: disabled)
Active: active (running) since Thu 2018-02-22 10:23:48 +04; 2s ago
Docs: http://docs.graylog.org/
Main PID: 6207 (graylog-server)
CGroup: /system.slice/graylog-server.service
±6207 /bin/sh /usr/share/graylog-server/bin/graylog-server
±6208 /usr/bin/java -Xms1g -Xmx1g -XX:NewRatio=1 -server -XX:+Res…

Feb 22 10:23:48 pdc-graylog-01 systemd[1]: Started Graylog server.
Feb 22 10:23:48 pdc-graylog-01 systemd[1]: Starting Graylog server…
[root@pdc-graylog-01 ~]#

[root@pdc-graylog-01 ~]# curl -x GETerror: _known_hosts_real: missing mandatory argument CWORD

curl: no URL specified!
curl: try ‘curl --help’ or ‘curl --manual’ for more information
[root@pdc-graylog-01 ~]# curl -X GET http://localhost:9200
{
“name” : “Whizzer”,
“cluster_name” : “PDC-GRAYLOG-01”,
“cluster_uuid” : “KYrbXWNQQO-xfxsLDY9LYg”,
“version” : {
“number” : “2.4.6”,
“build_hash” : “5376dca9f70f3abef96a77f4bb22720ace8240fd”,
“build_timestamp” : “2017-07-18T12:17:44Z”,
“build_snapshot” : false,
“lucene_version” : “5.5.4”
},
“tagline” : “You Know, for Search”
}
[root@pdc-graylog-01 ~]#


(Jochen) #7

@hamed Please properly format your text snippets, so that they’re readable:
http://commonmark.org/help/

Example:

```
Some text, ...
More text, ...
```

(Jochen) #8

What’s in the logs of your Graylog node? :arrow_right: http://docs.graylog.org/en/2.4/pages/configuration/file_location.html
Which version of Graylog are you running?
How are you trying to access the Graylog web interface?
Is 192.168.1.5 the IP address of the machine running Graylog?
Is 192.168.1.5 reachable from your machine?


(hamed) #9

version is 2.4.6
i aceess from local host to graylog that installed in hyper-v
192.168.1.5 is ip address of machine of local host machine


(hamed) #10

sorry for that this first time i use you website


(Jochen) #11

That’s the version of Elasticsearch. Which version of Graylog are you using?


(hamed) #12

sorry
the version of graylog is :2.1.3


(hamed) #13

if you want any information else please tell me
i need your help to work this.


(Jochen) #14

Please answer all questions from my previous post:

Also, what’s the output of the following command on your machine (the one with the web browser):

# ping -n 1 192.168.1.5

(system) #15

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.