Graylog with nginx-ingress-controller


I installed the graylog3 in a kubernetes EKS cluster. I am using nginx-ingress-controller.
However, the WEB interface does not work with HTTPS.

What settings on nginx-ingress do I have to enable?

Installing nginx-ingress

helm install nginx-ingress --namespace nginx-ingress \
      --set rbac.create = true \
      --set controller.kind = DaemonSet \
      --set controller.service.enableHttps = false \
      --set controller.service.type = NodePort \
      --set controller.service.nodePorts.http = 30000 \
      --set controller.metrics.enabled = true \
      --set controller.service.annotations. "kubernetes \ .io / ingress.class" = alb stable / nginx-ingress --version 1.36.0

Graylog installation

helm install graylog -n graylog \
--set graylog.rootPassword = xxxxxxxxx \
--set \
--set graylog.metrics.enabled = true \
--set graylog.ingress.enabled = true \
--set graylog.ingress.port = 30000 \
--set graylog.ingress.hosts.0 = \
--set graylog.externalUri = stable / graylog --version 1.6.2

I didn’t find anything in the helm graylog documentation about configuring nginx-ingress.

I’ve been trying to make graylog work in the kubernetes cluster for days with nginx-ingress.

Could you please help me?

I’m running Graylog v3.1.3 on EKS, but we are using an Istio Ingress gateway front-ended by and ALB created using alb-ingress-controller. Pretty slick, once it’s setup.

We also make use of the nginx-ingress controller for other workloads, but load from the project yaml, not helm chart, and use DaemonSet host ports instead of node ports.

When I look at the from the chart repo (link below) it seems to me like you’d also want to set and https node port if you wanted one of those.

So, add the following I think, replacing the XXXX with whatever node port you want in the 30k range.

--set controller.service.nodePorts.http = 3XXXX

Thanks for the reply and help.
We use nginx-ingress (istio is not yet at this level).
I installed nginx-ingress now using nodePort for HTTP and HTTS, but it still doesn’t work.

helm install nginx-ingress --namespace nginx-ingress \
       --set rbac.create = true \
       --set controller.kind = DaemonSet \
       --set controller.service.type = NodePort \
       --set controller.service.nodePorts.http = 30080 \
       --set controller.service.nodePorts.https = 30443 \
       --set controller.metrics.enabled = true \
       --set controller.service.annotations. "kubernetes\.io/ingress.class"=alb stable/nginx-ingress --version 1.36.0 

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.