Graylog with Kafka Input - max.request.size


(Zero) #1

Hello,
How can I configure stuff like “max.request.size” or “message.max.bytes” for Kafka input but on Graylog’s Consumer? I have run into problems where Kafka tried to send a 4MB message (4MB is our maximum Kafka-side) and Graylog’s consumer couldn’t consume it because it was too large.
Also: what are the default settings for max.request.size / message.max.bytes for Kafka input on Graylog?

Thanks for help!


#2

I don’t use kafka, but you operating System also can limit the max message size.


(Jan Doberstein) #3

he @Zerobot

Do you ask this for all Kafka inputs or for some specific? All input configuration is done on the input page and the settings of that input. If some option is not given, it is not possible to configure.


(Zero) #4

I’m asking about Kafka Raw/Plaintext Kafka.
Alright so it is not possible to set the message size, I guess it’s 1MB (Kafka’s default size).


(system) closed #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.