Graylog web UI can't connect to API

Hi! I will very appreciate anyhelp. This is the deal…
I have this graylog testing machine. Trying to login to web UI after start elasticsearch & graylog-server services, but I’m getting this error.

I already checked /etc/elasticsearch/elasticsearch.yml and /etc/graylog/server/server.conf, according to this link:
Tested connectivity with curl (it works). Checked systemd config file, file permissions, process owner, etc… but can’t fix this…

Tried setting rest_listen_api, rest_transport_api, web_listen_uri & web_transport_uri to http ://localhost:PORT, http ://, http :// & http ://PUBLIC_IP:PORT (with and without /api/ for each case) but still doesn’t work.
Tested each one of these with curl. The only worked is http://PUBLIC_IP:PORT
Checked firewall-cmd and have access rules for all traffic in ports 9000 and 9200.

Sorry for my english, is terribble.

I’ll very appreciate any help.


You have linked the Graylog 2.3 documentation, are you running Graylog 2.3?

If you are, since this is a test system you’ve brought up, I’d recommend installing the latest version.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.