Graylog Web Interface Language


(Jake Smith) #1

Dear Graylog,

Is my understanding correct that Graylog only supports English as a language for the web interface?

If I wanted to translate the web interface to Korean as an example, I would have to do it within the source code of the web interface and compile.

Cheers

Jake


(Jan Doberstein) #2

s my understanding correct that Graylog only supports English as a language for the web interface?

Yes

f I wanted to translate the web interface to Korean as an example, I would have to do it within the source code of the web interface and compile.

yes


(Jake Smith) #3

Hi Jan,

I am assuming this would also need to be done within plugins as well?

Kind Regards

Jake


(Jan Doberstein) #4

I am assuming this would also need to be done within plugins as well?

yes - as we do not have built in support to assist translation.


(Tess) #5

I was just about to ask: is Graylog built modularly, in such a way that all the messages and text field are pulled from a separate table or source file? That would make life a lot easier, when trying to offer translations. It’s an approach many project use: translators would simply have to copy the template text-string file and edit it for their own language.


(Jan Doberstein) #6

I was just about to ask: is Graylog built modularly, in such a way that all the messages and text field are pulled from a separate table or source file?

it is not


(Jake Smith) #7

Jan,

Been doing some research on localisation.

If i wanted to add a language, it would roughly consist of

  • Adding npm packages to support localisation as out of the box npm does not support any other language than english
  • Modifying source code to include localisation support

I was considering using the react-intl or i18next for localisation.

What do you think?

Cheers

Jake


(Jan Doberstein) #8

What do you think?

have fun.

You need to touch nearly all parts of Graylog so you need to make this a continuing task - all updates that are done by the Graylog team would need to be transfered to your repository and checked manually.


(Tess) #9

A big, new major version would of course be a great moment for big sweeping changes like switching to modular UI texts. But since 3.0 is right around the corner, that’s a bit too late. Perhaps for 4.0? :wink:


(Jan Doberstein) #10

make a wish (feature request) over in github and the gods of product managment might accept your prey.


(Jake Smith) #11

Hi Jan,

Have graylog-project-cli building with command line maven. I have installed all dependencies as well such as mongodb / elasticsearch

In the github repo screenshot, it shows a server run configuration in idea. If I go to Run/Debug configurations, I can see an option to create the same screenshot.

I thought about setting it up as a maven project as shown below

But that does not seem to be correct.

Any help appreciated as I would like to get a full working dev server.

Cheers

Jake


(Konrad Merz) #12

You should run it as Java Application with following configurations:
image

You also need a NPM configuration which will provide you with the frontend dev server:
image

Since you have a working build I am sure you can take on from here, but I’ll try to help you where I can.


(Ben van Staveren) #13

Does bribery with wine and cheese from France work to have the prayers accepted faster? :wink:


(Jake Smith) #14

Hi Konrad,

I am nearly complete, I have just a couple of the questions.

  1. in your NPM configuration screenshot, you are running a locally installed version, not one in the graylog source tree correct?
  2. I cant seem to select the runner class as in the screenshot below. Have I missed a Java dependancy somewhere? I have open-jdk 1.8 installed or is it just that I don’t know where to find the runner class selection.

Cheers

Jake


(Jake Smith) #15

Montagny Premier CRU plus saucisson and baquette monsieur


(Tess) #16

Omelette du fromage!


(Konrad Merz) #17

Hi Magneton,

At first happy new year!

  1. Yes I locally installed node, since the node installations from graylog are transient and might change version or names.
  2. Did you import your project via: maven? That should have find the runner module.

Sorry for the belated answer, but I enjoyed my holidays computer free :slight_smile:


(Jake Smith) #18

Hi Konrad,

I do holidays pretty much computer free as well except for first thing in the morning as I am a early riser.

I imported the project as a maven project from the graylog2 server directory in the source. IDEA said I had an unmanaged pom.xml and did I want to use maven, so I said ‘yes’.

I will check and come back to you.

Kind Regards

Jake


(Jake Smith) #19

Hi Konrad,

OK, I solved it. Just for reference for others, you need to import the graylog-parent project not the graylog2-server directory as a maven project then you can setupthe configuration correctly.

I also had to remove the node options to get node to start within IDEA.

However, it looks like my config file is invalid according to below

.shared.plugins.PluginLoader - Plugin directory /home/xxxx/graylog-project-repos/graylog2-server/plugin does not exist, not loading plugins.
2019-01-02 10:00:42,967 INFO : org.graylog2.bootstrap.CmdLineTool - Loaded plugin: AWS plugins 3.0.0-alpha.6-SNAPSHOT [org.graylog.aws.AWSPlugin]
2019-01-02 10:00:42,968 INFO : org.graylog2.bootstrap.CmdLineTool - Loaded plugin: Collector 3.0.0-alpha.6-SNAPSHOT [org.graylog.plugins.collector.CollectorPlugin]
2019-01-02 10:00:42,970 INFO : org.graylog2.bootstrap.CmdLineTool - Loaded plugin: Threat Intelligence Plugin 3.0.0-alpha.6-SNAPSHOT [org.graylog.plugins.threatintel.ThreatIntelPlugin]
2019-01-02 10:00:42,990 ERROR: org.graylog2.bootstrap.CmdLineTool - Invalid configuration
com.github.joschi.jadconfig.ValidationException: Parent path /etc/graylog/server for Node ID file at /etc/graylog/server/node-id is not a directory
at org.graylog2.Configuration$NodeIdFileValidator.validate(Configuration.java:296) ~[classes/:?]
at org.graylog2.Configuration$NodeIdFileValidator.validate(Configuration.java:284) ~[classes/:?]
at com.github.joschi.jadconfig.JadConfig.validateParameter(JadConfig.java:215) ~[jadconfig-0.13.0.jar:?]
at com.github.joschi.jadconfig.JadConfig.processClassFields(JadConfig.java:148) ~[jadconfig-0.13.0.jar:?]
at com.github.joschi.jadconfig.JadConfig.process(JadConfig.java:99) ~[jadconfig-0.13.0.jar:?]
at org.graylog2.bootstrap.CmdLineTool.processConfiguration(CmdLineTool.java:351) [classes/:?]
at org.graylog2.bootstrap.CmdLineTool.readConfiguration(CmdLineTool.java:344) [classes/:?]
at org.graylog2.bootstrap.CmdLineTool.run(CmdLineTool.java:178) [classes/:?]
at org.graylog2.bootstrap.Main.main(Main.java:44) [classes/:?]

Process finished with exit code 1

I think I am nearly there, just need to solve the the plugin directory not existing and the node-id.

Any help

Cheers

Jake


(Jake Smith) #20

Konrad,

Look what I have running

For final reference, I had to set graylog to listen on localhost address and comment out the node-id location in the graylog-server configuration file.

I suppose the next test is to get the localisation packages into npm and make sure that works within the package.json

After that the fun really begins…

Cheers

Jake