GrayLog Web interface does not respond

I have downloaded GrayLog OVA disk and run VMWare machine.
Then did as described:
$echo -n | shasum -a 256
The result copy and paste to /etc/graylog/server/server.conf
root_password_sha2=xxxxx

After VM restart I could connect to GL web interface , ok.
http://10.0.0.72:9000/dashboards

Then I have decided to upgrade the GL 3.3.8 to the latest one.
I have updated it using recommendations on GL site, server.conf was replaced with new one. I have generated hash again and added to the config
After restart VM this request
http://10.0.0.72:9000/dashboards
returns 404

What is wrong? How to fix it? Thank you

Hey @OlegDev,

Considering the time it would take to troubleshoot this problem, my recommendation would be to ditch the OVA and built a fresh all in one node on your preferred linux distro. That way there is no upgrade path to have to worry about.

Following this will get you there and if you hit any issues you can always post them back here.

If you are fully committed to that OVA life then I suggest you start by examining log file found under /var/log/graylog/server.log.

1 Like

I have found in the log
Parameter password_secret should not be blank

Should it be the same password which I used for generating hash or it another?

Nice!

As per the docs

  1. To create your password_secret, run the following command:
< /dev/urandom tr -dc A-Z-a-z-0-9 | head -c${1:-96};echo;
  1. Use the following command to create your root_password_sha2:
echo -n "Enter Password: " && head -1 </dev/stdin | tr -d '\n' | sha256sum | cut -d" " -f1

Ok, thank you, done, now the next error during GL start:

You’re running MongoDB 4.0.20 but Graylog requires at least MongoDB 5.0.0. Please upgrade.

How to upgrade MongoDB to 5.0.0 ?

I once again implore you to consider simply building the node from scratch, then you won’t face any of these issues.

Though if you must continue down this path here is an upgrade path from the docs

Will install clean Ubuntu 22.04, then GrayLog, then try :wink:
Thank you

1 Like

I have installed VMWare Ubuntu 22.04 Desktop, inside Ubuntu in Software installed Graylog, modified server.config (added secret_pasword and hash for the new admin password). After Ubuntu VM reboot tried in host machine browser
http://10.x.x.x:9000

404

Even on local VM 127.0.0.1:9000
Firefox can’t establish a connection to the server at 127.0.0.1:9000.

What to check else?

What are your http_bind_address , http_external_uri and http_publish_uri settings within your /etc/graylog/server/server.conf file?

Also, what is your route from browser to graylog server? I.e. are you on the same subnet? Are you traversing the WAN? Do you have a firewall enabled on your Graylog Server hypervisor and/or guest?

EDIT: Final question:
what does /var/log/graylog-server/server.log say? The web interface will fail to come up if it is failing to connect to opensearch/elasticsearch and/or mongodb.

I have run web interface after read server log file to the end and found the password there.
Ok, I have logged id with the temp pwd and then in the browser appeared initial page; ca, policy and requirement to add node.
I have installed the node in terminal, return back to browser and web page disappeared.
I read GL-server log:

INFO [cluster] Exception in monitor thread while connecting to server localhost:27017
com.mongodb.MongoSocketOpenException: Exception opening socket

How to fix it?

Is the mongo service running?

What does /etc/mongo.conf look like?