Can't access Graylog web interface, mongod, opensearch, graylog running ok

Before you post: Your responses to these questions will help the community help you. Please complete this template if you’re asking a support question.
Don’t forget to select tags to help index your topic!

1. Describe your incident:
I’m trying to setup GL to run on my Ubuntu 22.04 Test VM through Proxmox and I have setup MongoDB, Opensearch, and Graylog several times, but I always get stuck trying to access the web interface. I did it once but can’t recreate it.
(still a bit new to linux and coding in general but I’m trying to learn as much as I can)

2. Describe your environment:

  • OS Information: Linux, ubuntu 22.04

  • Package Version: MongoDB, Opensearch, Graylog

  • Service logs, configurations, and environment variables:

I have the /etc/graylog/server/server.conf file, and I also have the Opensearch configuration file as well in case its necessary.

3. What steps have you already taken to try and solve the problem?

I have reset the VM several times and tried to install MongoDB, Opensearch, and GL in the same way several times, but couldn’t access the web interface after the first time.

4. How can the community help?

If someone has a solution to this or has had the same problem and solved it themselves, I would love some guidance with it :slight_smile:

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]

Forgot to mention, MongoDB is v6, OpenSearch is v2, and Graylog is v5.

In a terminal on the host, run grep -v '^#' /etc/graylog/server/server.conf and paste the output here with the code tag:

Next, paste the contents of /var/log/graylog-server/server.log (check that, I’m pulling the file location from memory) again with the code tag. It may be profitable to systemctl stop graylog-server && systemctl start graylog-server first and then only paste the output from after the restart.

Finally, can you take a screenshot of the sign-in page or the error you are receiving when you attempt to sign in?


Thanks for the help, I forgot to close this, I was able to fix it by changing some of the rules in the server.conf file for GL. Sorry about that, and thanks again!

No worries! Glad you are up and running. Do you mind sharing your solution in case others run into the same issue?

Oh sure. It was really stupid and simple, and completely user-error, but when I was typing the IP address as a URL into my browser, I was including the “https://” at the front, which you can’t do unless you never want to see the GL web interface lol.

That’s probably because you don’t have a SSL certificate. Typing “http://” instead of “https://” is your solution. Typing just the IP resulted in redirecting to port 80 - http.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.