Graylog installation problems

1. Describe your incident:
I have followed the guide located here: https://go2docs.graylog.org/current/downloading_and_installing_graylog/ubuntu_installation.html on a brand new install of Ubuntu 22.04.04, but after completing the steps, I am unable to get to the webpage to log in to the system.

2. Describe your environment:

  • OS Information:
    Ubuntu Server 22.04.04
  • Package Version:
    I am trying to install Graylog Open 6.0
  • Service logs, configurations, and environment variables:
    This is a brand-new install. I am happy to provide these, but looking at the log files I know about, I don’t see any errors indicating why this isn’t working.

3. What steps have you already taken to try to solve the problem?
I followed the steps multiple times, formatted and reloaded the server, and tried again. All installed services from this tutorial are running, and as far as I can tell, there are no errors in the logs. I am missing something, but I am not sure where to look.

4. How can the community help?
It would be very helpful if I could get some help troubleshooting this or have suggestions about what log files to examine.

Thank you,

Hey @TechD

Is all your service working ? Graylog, OpenSearch and MongoDb.
Have you check Graylog log file see if there are errors/Warnings?

Please disregard this, as I got it to work.

I followed the guide, but for the MongoDB and OpenSearch installation portions, I followed the guides’ links for the versions I was installing.

After doing so, I was presented with a different login prompt. I tried the passwords I had set with no success. I found an article mentioning checking the Graylog logs cat /var/log/graylog-server/server.log,, and in there, I found a password that would allow me to log in.

Apparently, I just needed to ask for help, and I would be able to provide this help to myself.
Thank you for all.

1 Like

There would have been somehting wrong with your settings in server.conf related to the connection to opensearch. When this happens you are forced into the preflight environment which has that password from the log file etc. Then in preflight it will run you through some things that will fix that connection.