Graylog timestamp issue


(Andrew Ferdinandus) #1

Hi i have a problem with my timezones. Dashboard Overview setting time configurations are all equal. Time Zone setting in the server show is below.
When i do the Absolute search between current day and +1 day Logs are recieving. but there is a +6.30 hours difference between the timestamp and the log date/time.
Logs are not showing on the search area for Relative search “Last 5 Minutes” but You can see its reciveing on the right side upper pane. Could anyone help me to overcome this issue.


(Jochen) #2

Graylog expects the timestamp in the syslog message to contain timezone information or defaults to UTC.

Also see these related issues:
https://github.com/Graylog2/graylog2-server/issues/3091


(Andrew Ferdinandus) #3

Hi,

Thank you for the information. Actually fortigate device date format is “date=2017-09-18 time=14:15:05” and there is no an option to change the timestamp from the device. If we set our time zone into UTC the time will be changed within a huge gap. its not a good option for the vpn services and etc… are there any other solutions?


(Jochen) #4

You can try using the processing pipelines to move the timestamp into the correct timezone.

http://docs.graylog.org/en/2.3/pages/pipelines.html


(Andrew Ferdinandus) #5

Raw/Plaintext UDP worked successfully for me while ago. Thank you very much for the support given.


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.