Graylog thinks it's unable to start Inputs with error message "Address already in use", even though ports are open and everything seems to be working


(Julio H Morimoto) #1

Trying to use this neat marketplace content pack (nginx by lennartkoopmann) for nginx logs. After installing the content pack, it all seems to be ready, except Graylog shows the created Inputs marked as Failed.

In the Overview panel, this error message appears:

input 5a4bc0be12522a5ae7bf6fb4 has failed to start on node 16aeb6a2-ee66-4459-a9f6-dea685b638a4 for this reason: »Address already in use.«. This means that you are unable to receive any messages from this input. This is mostly an indication for a misconfiguration or an error. You can click here to solve this.

However, everything seems to be working fine.

I can also guarantee the ports are only being used by the Graylog because this particular instance runs inside a container in a Kubernetes setup. Graylog JVM is the only process running in that container. Logs are coming in at the expected ports from remote nginx instances.

This seems like a problem with Graylog showing the Input status; could be trying to start the same input twice?

I can change the input port and the error message goes away. However, it’s right back to the same error once the Graylog container is restarted.

Anyone else going throught this? Already tried asking on Github, but they directed me to this forum.

Thanks in advance for any help.


(Julio H Morimoto) #2

This is what the Input configuration looks like


(Jochen) #3

(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.