Graylog service failure

Hello there,
everything was working properly. I increased the processor and memory of the graylog server. I reboot the server. service does not start now. restarting but failing after 15-20 seconds

I restarted service mongod and elasticsearch. i can’t find another solution

I’m waiting for your help

your Graylog server.log should give you the reason for that.

1 Like

Thank you for your answer
I checked ;
2019-07-12T11:16:47.642Z ERROR [CmdLineTool] Guice error (more detail on log level debug): Error injecting constructor, java.lang.RuntimeException: kafka.common.KafkaException: Failed to acquire lock on file .lock in /var/lib/graylog-server/journal. A Kafka instance in another process or thread is using this directory.

I looked at other issues. message journal There may be a problem with dir permissions. but I checked it doesn’t seem to be a problem. Do you have any other ideas?

i solved the problem I checked the log file and made a small change to the server.conf file

The wrong directory was given in the message journal dir section worked when you gave the right directory.

thanks for help jan

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.