Graylog Plugin UI not showing


#1

After running mvn package on my plugin and putting the jar in the plugins folder. The logs show Loaded plugin: Logo Replacer 1.0.0 [org.graylog.plugins.logo.LogoReplacerPlugin].

The plugin is s System Configuration component. It shows on the UI on my development server running in Intellij. But not on the graylog server running in production. My thought is that assets were not built but I thought that this was done when I ran mvn package. Do I need to compile react assets!?


Graylog plugin UI not coming up in production server
(Jochen) #2

Did you build the plugin against the same version of Graylog that you’re running in production?


#3

No… I built it against version 2.3.0.rc-snapshot and I believe we are running 2.2.3 in production


#4

I changed my pom.xml to have…

<parent>
        <groupId>org.graylog.plugins</groupId>
        <artifactId>graylog-plugin-web-parent</artifactId>
        <version>[2.0.0,)</version>
        <relativePath>../graylog2-server/graylog-plugin-parent/graylog-plugin-web-parent</relativePath>
</parent>

As my plugin works on anything higher then graylog 2.0


#5

After making the above update, my plugin still shows it loading in the logs. But I do not see it on the System/Configurations page. Any other thoughts!?

Here is the code graylog-plugin-logo-replacer


(Jochen) #6

The checked out version of the Graylog web interface (via the Graylog2/graylog2-server repository) has to be compatible with the version of Graylog you want to use the plugin with.

Please use the graylog-project aggregation project to make this work.


#7

Is there an easy way to rollback my whole project from graylog 2.3 to 2.2. Other then running graylog-ctl bootstrap command again with the 2.2 sources.


(Jochen) #8

What do you mean exactly?


#9

I ran the graylog-ctl and am on Graylog 2.3.rc-snapshot. My production is running in 2.2.3. So is there a way I can checkout the graylog-project with version 2.2.3 so I can test my plugin with that?

So after looking into production console logs… it seems my plugin is having trouble with webpack.

vendor.js:1 Uncaught TypeError: Cannot read property 'call' of undefined
    at t (vendor.js:1)
    at Object.<anonymous> (global.js from dll-reference __vendor:1)
    at e (bootstrap 1dc9493…:19)
    at Object.<anonymous> (plugin.org.graylog.plugins.logo.LogoReplacerPlugin.1dc9493….js:64253)
    at e (bootstrap 1dc9493…:19)
    at v (URI.js:18)
    at Object.<anonymous> (URI.js:21)
    at e (bootstrap 1dc9493…:19)
    at Object.<anonymous> (webpack-entry.js:1)
    at e (bootstrap 1dc9493…:19)
    at Object.<anonymous> (index.jsx:2)
    at e (bootstrap 1dc9493…:19)
    at bootstrap 1dc9493…:65
    at bootstrap 1dc9493…:65

Clicking the error shows this line of code

/* WEBPACK VAR INJECTION */}.call(exports, __webpack_require__(28)(module), __webpack_require__(19)))

(Jochen) #10

Yes, of course.

You can check out all relevant repositories using graylog-project-cli by checking out the 2.2 manifest. Additionally, all Graylog releases are tagged in the graylog2-server repository.


#11

After using the graylog-ctl to checkout 2.2.json manifest. All my repos say that I am on master still. And all my files still say 2.3.rc-snapshot.


#12

SO I went ahead and just checkout origin/2.2 myself. graylog 2 server updated and all the dependencies did as well. the server builds fine in intellij. but when I run node (./node/npm run start). i get a error Webpack has been initialised using a configuration object that does not match the API schema.


#13

After running mvn compile on the graylog-project folder (building new dependencies for 2.2 for my plugin). Then allowing intellij to import these. Building/running graylog and the frontend worked fine.


(system) #14

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.