ERROR [CmdLineTool] Plugin "CustomAlert" requires version 4.2.14-SNAPSHOT - not loading!

I recently bootstrapped the Graylog 4.2.0 code from Git, using the below command.

graylog-project.linux bootstrap github://Graylog2/graylog-project.git --manifest manifests/4.2.json

This generated code with version 4.2.14-SNAPSHOT in the pom file for each of the plugins and graylog2-server parent.

So when I try to load the plugin I built, it gives me the below error.
ERROR [CmdLineTool] Plugin “CustomAlert” requires version 4.2.14-SNAPSHOT - not loading!

My graylog server in production runs 4.2.9. I somewhat figure that this might be an issue for my plugin but I am only guessing. I have created a manifest file “release-4.2.9.json” and tried to match my version. However, this failed to checkout/bootstrap.

For me to build a plugin for Graylog, is it important I adjust the pom file versions to match the specific version of Graylog that I have? Sorry to ask a question that might seem to have an obvious answer but I just need some affirmation on my guessing.

Hey @ofentselogger

You could test this out on a Dev VM that is the same version see if it works.

Thanks @gsmith - I can do so but I notice a short coming in the real world scenario I face.

Graylog Server repo for Red Hat only has up to version 4.2.13. And if I check out the 4.2.0 line, it goes up to update 14. Of course, in the dev world, I can check out Graylog 4.2.14 I guess and be able to bootstrap the corresponding plugin version.

I will test your idea out. but is there also a means to suppress the version check?

That doesn seam correct, you should be able to go to version Graylog 4.3.10.
This would mean correcting your Graylog repo on this Graylog server.

Red Hat upgrade steps.

sudo yum clean all

sudo rpm -Uvh

sudo yum update

sudo yum install graylog-server graylog-enterprise-plugins graylog-integrations-plugins graylog-enterprise-integrations-plugins

I maybe wrong, where are you getting Graylog version 4.2.13/14 at ?

I can only find 4.2.12 here

@ofentselogger sorry I missed this question

I’m not sure if this is what you wanted but In Graylog configuration file you should have this line.

# Disable checking the version of Elasticsearch for being compatible with this Graylog release.
# WARNING: Using Graylog with unsupported and untested versions of Elasticsearch may lead to data loss!
elasticsearch_disable_version_check = true

Thanks. This is helping jog my mind a bit. Sorry, I didn’t mean 4.2.13 but I meant 4.2.12. However, you give a better example.

You say I can go to 4.3.10 (actually 4.3.11). If I use the manifest file to checkout the 4.3.0 branch, I will get 4.3.12-SNAPSHOT according to the below pom.xml file output. But in production main release it is 4.3.11. The manifests json file do not have a 4.3.0 file. Is there a way of creating the manifest file so I don’t bootstrap the master plugin skeleton? If there is then I can bootstrap 4.3.11


Hey @ofentselogger

My appologies, I read your statment wrong from the begining. I was assuming you just want you upgrade your system, while over looking that your using graylog-project. I havent use graylog-project but for something like this Im wondering if you could get a response back from posting here? Correct me if I’m wrong but I think thats what you doing meaning building Graylog?

Thank you, yes this is what I meant. Sorry if my problem statement was not clear. But I must say you have given me good ideas that will be helpful.

I have posted in the github project issues area. While I wait I am also busy planning using the other suggestions you made.

Oh you were clear, I just cant read well :laughing: Awsome :smiley: I try.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.