Graylog not found any syslog

Before you post: Your responses to these questions will help the community help you. Please complete this template if you’re asking a support question.
Don’t forget to select tags to help index your topic!

1. Describe your incident:

When i installed the graylog 4.2x,i can not found any syslog from the network device.

2. Describe your environment:

  • OS Information:Graylog v4.2.8+c9edd92

  • Package Version:

  • Service logs, configurations, and environment variables:

3. What steps have you already taken to try and solve the problem?

I have increasd the jvm form 1g to 6g and set the receive buffer,checked the logfile not found any error message.but it still not working.Plese help.

4. How can the community help?

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]

i have tried edited iptables as shown:
iptables -t nat -A PREROUTING -p tcp --dport 514 -j REDIRECT --to 1514
iptables -t nat -A PREROUTING -p udp --dport 514 -j REDIRECT --to 1514
service iptables save

What is your syslog coming from? Your input is syslog UDP, maybe you are sending syslog TCP?

I have checked the syslog is using UDP protocol.

Hello @teamonelove

Not sure if you have seen this post , but it may have some ideas on how to fix this issue.

It does some Iptables configurations shown from this member also.

1 Like

Hi gsmit,

Thank you for your reminder,It turned out that my iptable was not started… Now the problem has been solved, thank you for your help. :grinning:

It happens to all of us at one time or another :laughing:

If you could make this as resolved that would be great :+1:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.