Graylog nodes not initializing


(James) #1

I have built a new 6 server test graylog deployment. 3 node Elasticsearch cluster and 3 node dual graylog/mongo cluster. Elasticsearch and mongo test as healthy using the commands on their websites. Once I start the graylog service it makes a connection to mongo then repeats the same lines over and over. It never fully starts. Below are the lines it repeats as well as heath status from Elasticsearch and mongo. Also I am including my graylog config file. If anyone has any suggestions, that would be greatly appreciated.

–Repeating lines from /var/log/graylog-server/server.log–
–It never gets passed this–
[plugins] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] modules [], plugins [graylog-monitor], sites []
[node] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] version[2.4.4], pid[3288], build[fcbb46d/2017-01-03T11:33:16Z]
[node] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] initializing …
[plugins] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] modules [], plugins [graylog-monitor], sites []
[node] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] version[2.4.4], pid[3288], build[fcbb46d/2017-01-03T11:33:16Z]
[node] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] initializing …
[plugins] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] modules [], plugins [graylog-monitor], sites []
[node] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] version[2.4.4], pid[3288], build[fcbb46d/2017-01-03T11:33:16Z]
[node] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] initializing …
[plugins] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] modules [], plugins [graylog-monitor], sites []
[node] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] version[2.4.4], pid[3288], build[fcbb46d/2017-01-03T11:33:16Z]
[node] [graylog-48d71416-9d8e-4a9f-8b0f-67c8ff3403d6] initializing …

Full service start log - https://pastebin.com/pNpjr4qb

Per the setup instructions firewalld and selinux have been disabled on all nodes

RS Status from Mongo - https://pastebin.com/MbhQPipt
Health report from ElasticSearch - https://pastebin.com/fE5MfhD4
Graylog Config file - https://pastebin.com/4adtnQqG

Installed versions on graylog/mongo servers:
[root@uclogglsrv01 ~]# yum list installed | grep -i "mongo|graylog"
graylog-2.2-repository.noarch 1-5 installed
graylog-server.noarch 2.2.3-1 @graylog
mongodb-org.x86_64 3.4.4-1.el7 @mongodb-org-3.4
mongodb-org-mongos.x86_64 3.4.4-1.el7 @mongodb-org-3.4
mongodb-org-server.x86_64 3.4.4-1.el7 @mongodb-org-3.4
mongodb-org-shell.x86_64 3.4.4-1.el7 @mongodb-org-3.4
mongodb-org-tools.x86_64 3.4.4-1.el7 @mongodb-org-3.4

If you think there is anything I can add to help find the issue please let me know. Thank you.


(Jan Doberstein) #2

you should check your rest_listen_uri and rest_transport_uri - the way you have it configured is bogus and can create that behavior - please re-read the documentation.


(James) #3

Jan,

I have tried several combinations with no luck (listed many of them below). This is my first time deploying graylog and maybe I am misunderstanding something that is pretty simple.

Looking at the chef cookbook online for the 2.2.3 version it shows to use http://0.0.0.0:9000/api/ for the rest_listen_uri and http://0.0.0.0:9000/ for the web_listen_uri with the transport left commented out. However if I do that it gives an error stating that you can’t use wild cards on the same port. That makes sense and I agree, I just don’t know why it has that as in the settings file if it shouldn’t work.
https://github.com/Graylog2/graylog2-cookbook/blob/master/attributes/default.rb

Combinations I have tried:
rest_listen_uri = http://127.0.0.1:12900/
rest_transport_uri = http://10.80.1.191:12900/api/
web_listen_uri = http://127.0.0.1:9000/

rest_listen_uri = http://0.0.0.0:12900/api/
rest_transport_uri = http://10.80.1.191:12900/
web_listen_uri = http://0.0.0.0:9000/

rest_listen_uri = http://0.0.0.0:12900/
rest_transport_uri = http://10.80.1.191:12900/api/
web_listen_uri = http://0.0.0.0:9000/

rest_listen_uri = http://uclogglsrv01:12900/api/
rest_transport_uri = http://uclogglsrv01:12900/
web_listen_uri = http://uclogglsrv01:9000/

#this one fails because using the wildcard on port 9000 for both options
rest_listen_uri = http://0.0.0.0:9000/api/
rest_transport_uri = http://10.80.1.191:12900/
web_listen_uri = http://0.0.0.0:9000/

rest_listen_uri = http://0.0.0.0:12900/api/
rest_transport_uri = http://10.80.1.191:9100/
web_listen_uri = http://0.0.0.0:9000/

If you have any other suggestions please let me know and thank you very much for your assistance.


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.