Graylog docker - http notification error

I’m able to install graylog docker via documents - quick start.

I can send POST request with curl -X POST -H "Content-Type: application/json" -d "{}" with cors enabled, and it responds with status:200. Also I can receive the right message {}

I disabled the whitelist in graylog, so I can send the message to wherever I want.

But in Alters > notification tab, I received following message, and couldn’t receive any data with my server.

Am running graylog on and How to fix the issue ?


so you run your Graylog in a docker container and point to localhost … did you forward the localhost from inside the Graylog docker container to your notification container/service or did you run that inside the same container? IN the Graylog container is different from of your workstation.

Yeah. I’m pretty new to the docker.
Here is what I also tried:
1—expose 8080 and 2 send the msg through

Ideally I want to 3 bind graylog’s port to 8080 -p 8080:8080 and use the same port as my server, but it throws “port already in use” error.

4 send msg through

I tried different combinations, but none of them worked.

he @Truth1984

maybe this will help you to understand networking in docker:

issue solved with:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.